Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найти количество букв "а" в тексте

5-9 класс

напишите на C++

Lerochkalera 05 янв. 2015 г., 20:33:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nurmakova00
05 янв. 2015 г., 21:55:58 (9 лет назад)


#include
#include
#include

int main()
{
char str[10];
int i, n, an;
cin >> str;
n=strlen(str);
for( i=0; i<=n; i++ )
{
if( str[i]=='a')
{
sn++;
}

}

cout<<"a ="<
getch();
return 0;
}

Ответить

Другие вопросы из категории

Читайте также

Автомобильный номер состоит из нескольких букв ( количество букв одинаковое во всех номерах ), за которыми следуют 4 цифры. При этом используются 10 цифр

и только 5 букв: Р, О, М, А, Н. Нужно иметь не менее 1 000 000 различных номеров. Какое наименьшее количество букв должно быть в автомобильном номере? 1) 1 2) 2 3) 3 4) 4

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Изменится ли строка ST, над которой произведут операцию COPY? Почему?

Чему будет равняться k после операции k:=length(‘мышь и клавиатура’)?

Чему будет равняться переменная tx после операции tx:=‘лесник’; delete(tx,4,3)?

Чему будет равняться переменная k после операции tx:=‘баобаб’; k:=pos(‘ба’,tx)?

Дополнить программу недостающими командами

Подсчитать количество букв “а” в тексте (русских и латинских; прописных и заглавных).

program zadacha1;

var t:string;

b:string[1];

n,k,i:integer;

Begin

writeln('Введите текст');

…………………………;

n:=length(t);

k:=0;

for i:=1 to n do

begin

b:=copy(t,i,1);

if ……………………………then k:=k+1;

end;

writeln('k=',k);

End.

Частотный словарь русского языка — словарь вероятностей (частот) появления букв в произвольном тексте – приведен ниже. Определите, какое количество

информации несет каждая буква этого словаря.

Символ

Частота

Символ

Частота

Символ

Частота

Символ

Частота

о 0.090 в 0.035 я 0.018 ж 0.007
е, е 0.072 к 0.028 Ы, 3 0.016 ю, ш 0.006
а, и 0.062 м 0.026 ь, ъ, б 0.014 ц, щ, э 0.003
т, н 0.053 д 0.025 ч 0.013 ф 0.002
с 0.045 п 0.023 й 0.012
р 0.040 У 0.021 X 0.009
2. Используя результат решения предыдущей задачи, определите количество информации в слове “компьютер”.



Вы находитесь на странице вопроса "Найти количество букв "а" в тексте", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.