Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано: массив целых чисел A[N].Проверьте, есть ли в нем отрицательные элементы.Если есть, найдите наибольшее i, при котором A[i]<0, иначе выведите

10-11 класс

сообщение. Напишите программу для Паскаль или лазарус

Ruslan1250807 17 дек. 2016 г., 19:43:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hkrn
17 дек. 2016 г., 21:09:09 (7 лет назад)

program gt;
var a:array[1..1000]of integer;
i,n,l:integer;
begin
read(n);
l:=0;
for i:=1 to n do
begin
read(a[i]);
if(a[i]<0)then l:=i;
end;
if(l=0)then writeln('НЕТ ОТРИЦА... В массиве')else writeln(l);
end.

Ответить

Другие вопросы из категории

1. Определить значения целочисленной переменной S после выполнения алгоритмов:

a). S:=1, a:=1
для i от 1 до 3 повторять
нц
S:=S+ix(i+1)a
a:=a+2
кц
(Составьте блок-схему),
б). Для i от 1 до 3 повторять
нц
S:=0
для j от 2 до 2 повторять
нц
S:=i+j
Кц
Кц
(Составить блок-схему)
2). Последовательно вводятся N целых чисел. Найти максимальное из них.

Соединить по смыслуСоединить по смыслу свойства информации с жизненными ситуациями.

1. Доступность информации.
2. Своевременность информации.
3. Достоверность информации.
4.Устойчивость информации.

А. Расписание уроков не меняется.
Б. В газете написано то, что соответствует действительности.
В. Сообщение пришло с опозданием.
Г. Сообщение написано на незнакомом языке.

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Помогите решить задачу. Pascal

Дан массив
целых чисел К(15), найти и вывести на печать отрицательные элементы из
этого массива.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Дано: массив целых чисел A[N].Проверьте, есть ли в нем отрицательные элементы.Если есть, найдите наибольшее i, при котором A[i]&lt;0, иначе выведите", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.