Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста

10-11 класс

Решить задачу структурным способом записи через блоки
program fwe;
var i,k,m,n:integer;
var a,b,h,c,g,s,s1,x,yk,yn,y1:real;
begin
writeln('Vedite predeli integrirov');
readln(a,b);
writeln('Vedite kol-vo oterzkov');
readln(k);
x:=a;c:=1;s:=0;
h:=(b-a)/k;
m:=k-1;
for i:=1 to m do
begin
x:=x+h;
s:=s+(3+c)*sqrt(x+3/x);
c:=-c;
end;
s1:=sqrt(a+3/a)+sqrt(b+3/b);
s:=h*(s1+s)/3;
writeln('Ickomoe znach ravno', s:9:10);
readln;
begin
writeln('Vedite peredeli integri');
readln(a,b);
writeln('Vedite kol-vo otrezkov');
readln(n);
h:=(b-a)/n;
y1:=0;
x:=a;
for i:=1 to n-1 do
begin
x:=x+h;
y1:=y1+sqrt(x+3/x);
end;
yn:=sqrt(a+3/a);
yk:=sqrt(b+3/b);
s:=((yn+yk)/2+y1)*h;
writeln('Ickomoe zhach ravno',s:9:10);
readln;
end;
end.

Skupi 15 мая 2014 г., 12:57:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Toropova1997
15 мая 2014 г., 14:05:45 (9 лет назад)

program fwe;

function Intg1(a, b: real; k: integer): real;
var
  x, h, s, s1: real;
  c, m, i: integer;
begin
  x := a; c := 1; s := 0;
  h := (b - a) / k;
  m := k - 1;
  for i := 1 to m do
  begin
    x := x + h;
    s := s + (3 + c) * sqrt(x + 3 / x);
    c := -c
  end;
  s1 := sqrt(a + 3 / a) + sqrt(b + 3 / b);
  Intg1 := h * (s1 + s) / 3
end;

function Intg2(a, b: real; n: integer): real;
var
  x, h, y1, yn, yk: real;
  i: integer;
begin
  h := (b - a) / n;
  y1 := 0;
  x := a;
  for i := 1 to n - 1 do
  begin
    x := x + h;
    y1 := y1 + sqrt(x + 3 / x)
  end;
  yn := sqrt(a + 3 / a);
  yk := sqrt(b + 3 / b);
  Intg2 := ((yn + yk) / 2 + y1) * h
end;

procedure vvod(var a: real; var b: real; var k: integer);
begin
  writeln('Vedite predeli integrirov ');
  readln(a, b);
  writeln('Vedite kol-vo oterzkov ');
  readln(k);
end;

var
  a, b: real;
  n: integer;

begin
  vvod(a, b, n);
  writeln('Ickomoe znach ravno ', Intg1(a, b, n):9:10);
  readln;
  vvod(a, b, n);
  writeln('Ickomoe zhach ravno ', Intg2(a, b, n):9:10);
  readln;
end.

Ответить

Другие вопросы из категории

Составить блок схему. Составить программу вычисления значений функции F(х) на отрезке [а;в] с шагом h. Результат представить в виде таблицы, первый

столбец которой - значения аргумента, второй - соответствующие значения функции.
F(x) =  \sqrt{x} ·  cos^{2} х.

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.