Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста - это Паскаль

10-11 класс

Saveliymatveev 04 окт. 2013 г., 11:40:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Виолеттачка
04 окт. 2013 г., 13:23:34 (10 лет назад)

Как-то так
const a=5.8; x1=-3; x2=3; dx=0.5;
var x,k,p,s:real;
function t(i:real):real;
begin
result:=sqr(sin(i-4))
end;
function y(i:real):real;
beginif t(i)>=5 then result:=sin(pi/2+i)/cos(pi/2-i) else result:=ln(a+i)/sqr(a)
end;
begin
x:=x1; k:=0; s:=0; p:=1;
while x<=x2 do
begin
writeln('x = ',x,' y = ',y(x),' t = ',t(x));
if y(x)<0 then k:=k+1;
if t(x)>=0 then begin s:=s+t(x); p:=p*t(x) end;
x:=x+dx;
end;
writeln('k = ',k,' P = ',p,' S = ',s)
end.

+ 0 -
лсш
04 окт. 2013 г., 14:27:24 (10 лет назад)

Комментарий удален

+ 0 -
Alexzobova
04 окт. 2013 г., 15:08:38 (10 лет назад)

Комментарий удален

+ 0 -
Tby090214
04 окт. 2013 г., 16:31:19 (10 лет назад)

Так, а где sin|x-4| все-таки модуль или просто скобки?

+ 0 -
Александра22896
04 окт. 2013 г., 18:27:39 (10 лет назад)

скобки

+ 0 -
Miroooonenko
04 окт. 2013 г., 20:10:46 (10 лет назад)

Ясно

Ответить

Другие вопросы из категории

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Помогите!!!!

Прошу помогите, умоляю.........
Это Паскаль.....

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".



Вы находитесь на странице вопроса "Помогите пожалуйста - это Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.