Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Составьте программу вычисления суммы цифр трёхзначного числа а. значение а введите с клавиатуры.

5-9 класс

Pvclol 25 нояб. 2013 г., 2:43:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valerijazholobova
25 нояб. 2013 г., 5:24:24 (10 лет назад)

Program summa_4isel;
Uses crt;
Var a,e,z,y,x:integer;
Begin
Writeln('Введите трехзначное число число');
Readln(a);
x:=a div 100;
y:=(a-x*100) div 10;
z:=a-y*10-x*100;
e:=x+y+z;
writeln('Сумма чисел ',x,' ',y,' и ',z,' равна ',e,'.'); 
end.

Ответить

Другие вопросы из категории

Ребят помогите информатика.
ОЧЕНЬ СРОЧНО

Привет, мне нужна помощь с заданием по информатике. С таблицей Pascal.

Написать программу для нахождения площади кольца, внешний радиус которого равен R1, а внутренний R2, (R1>R2). Протестировали программу для R1=5.6 , R2=3.8 . Проверить ответ на калькуляторе

Читайте также

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3. 2) Составьте программу вычисления в массиве B(8) суммы отрицательных

элементов. 3) Составьте программу вычисления среднего арифметического элементов массива. Пожалуйста.. очень надо!

1. Составьте блок-схему алгоритма и программу вычисления площади треугольника по трем сторонам. 2. Составьте программу вычисления объема, площади полной

поверхности, суммы ребер прямоугольного параллелепипеда. 3. Составьте программу вычисления диагоналей ромба по стороне и углу.



Вы находитесь на странице вопроса "Составьте программу вычисления суммы цифр трёхзначного числа а. значение а введите с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.