Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан текст . Каждую точку в нём заменить двумя точками

10-11 класс

Yarmuhamedova 31 дек. 2013 г., 23:26:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rembo600
01 янв. 2014 г., 2:04:54 (10 лет назад)

 var s:string;
i:integer;
begin
write('Введите текст: ');readln(s);
for i:=1 to length(s) do
if s[i]='.' then write('..') else write(s[i]);
end.

+ 0 -
Artkov2000
01 янв. 2014 г., 4:23:03 (10 лет назад)

эмм если заметить точку двоеточием, то текст/словосочетание потеряет смысл

+ 0 -
Хасиба17
01 янв. 2014 г., 4:53:42 (10 лет назад)

Это программа по информатике : Дан текст . Каждую точку в нём заменить двумя точками - условие
Мне бы решение

+ 0 -
Katyakk
01 янв. 2014 г., 6:56:17 (10 лет назад)

лол сорри я на предмет не посмотрела xD

+ 0 -
79530403016
01 янв. 2014 г., 9:30:44 (10 лет назад)

ГДЕ????????????????????????????????!???????????????????!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

+ 0 -
12primercom571
01 янв. 2014 г., 10:57:08 (10 лет назад)

та забей, просто я тупая

Ответить

Читайте также

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Дано множество точек с координатами на плоскости.

Написать программу, которая использует подпрограммы и выведит на экран наименьшее расстояние между двумя точками.

1. Для записи текста, каждая страница которого состоит из 28 строк по 65 символов, использовался 16-символьный алфавит. Какой объем информации в Кбайтах

содержат 5 страниц текста?
2. На предприятии имеется 9 автомобилей ГАЗ, 1 автомобилей ЗИЛ, 9 автомобилей КаМАЗ, 4 автомобилей MAN. Какое количество информации несет сообщение о выезде с территории автомобиля каждого вида?

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их

кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.



Вы находитесь на странице вопроса "Дан текст . Каждую точку в нём заменить двумя точками", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.