Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

даны два положительних числа а и b.не применяя операции деления найти остаток от деления а на b

5-9 класс

Aigul1986N 24 авг. 2013 г., 13:44:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sanekchirgun
24 авг. 2013 г., 16:14:06 (10 лет назад)

uses crt;
var a,b,c,i:integer;
begin
  write('a='); readln(a);
  write('b='); readln(b);
  i:=1;
  while c<a do
  begin
    c:=b*i;
    i:=i+1;
  end;
  c:=c-b;
  writeln('остаток(a:b)=',a-c);
end.

Ответить

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

Дано целое число N и набор из N целых чисел. Найти минимальное положительное число из данного набора. Если положительные числа в наборе отсутсвуют, то

вывести 0.
С выводом минимального положительного числа у меня вроде бы получилось, а вот с проверкой на отрицательность не вышло



Вы находитесь на странице вопроса "даны два положительних числа а и b.не применяя операции деления найти остаток от деления а на b", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.