Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

5-9 класс

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

Krasava200212 24 апр. 2015 г., 13:16:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ezek2
24 апр. 2015 г., 15:30:20 (9 лет назад)

1)

 

var
a, b: integer;
begin
writeln('Введите a, b: '); readln(a, b);
if(b mod a = 0) then writeln('Является делителем')
else writeln('Не является делителем');
end.

 

2)

 

var
x, y, tmp: real;
begin
repeat
writeln('Введите x, y: '); readln(x, y);
until(x <> y);
if(x > y) then begin
tmp := y;
y := (x + y) / 2;
x := 2*(x * tmp);
writeln('Большее - X = ', x, ' Меньшее - Y = ', y);
end else begin
tmp := x;
x := (x + y) / 2;
y := 2*(tmp * y);
writeln('Большее - Y = ', y, ' Меньшее - X = ', x);
end;
end.

 

Ответить

Другие вопросы из категории

Начертите фигуру, изображенную на рисунке, используя вспомогательный

алгоритм с аргументами для рисования отдельного элемента. Количество
повторений витков спирали задается пользователем.

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

1)Ввести 2 числа,заменить число суммой чисел,а большее произведением. 2)Ввести 2 числа А и В заменить первое нулем если оно меньше второго. 3)Журнал стоит

k руб.Какую сдачу получит покупатель если у него в руб. 4)Определить ,является ли введенное шестизначное число счастливым,т.е. сумма первых трех цифр числа равна сумме последних трех цифр. 5)Определить ,является число А делителем числа В.

Ребят, очень срочно надо!! Помогите :) Информатика 9 класс)

Ветвление и выбор:
1) Определить min значение из трёх заданных чисел.
2) Определить является ли двух значимое число таким, что сумма цифр его ровна заданному значению а (а=1 до 9)
3) Определить по введенному количеству баллов оценку.
4) Определить кратность введенного трёхзначного числа к 3,через признак делимости на 3.
5) Определить по введенному количеству баллов полученных на экзамен. учебное заведение, в которые может попасть выпускник. max количество баллов 300 не менее 4 учебных заведений.

Составьте программу,

которая определяет, является ли введенное целое число нечетным, и выводит на
экран соответствующее сообщение: «Да, число нечетное» или «Нет, число четное».



Вы находитесь на странице вопроса "1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.