Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны 2 числа.Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.

10-11 класс

Arhey 14 авг. 2014 г., 16:29:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashkaangelok
14 авг. 2014 г., 17:36:13 (9 лет назад)

var

  a, b: real;

 

begin

  writeln('Введите два числа');

  readln(a, b);  //Вводим числа а и b

  writeln('Среднее арифметическое кубов этих чисел:  ', ((a * a * a) + (b * b * b)) / 2 : 0 : 5);  {Печатаем среднее арифметическое кубов этих чисел с округлением до 5 знаков после запятой}

  writeln('Среднее геометрическое модулей этих чисел:  ', sqrt(abs(a) * abs(b)) : 0 : 5);  {Печатаем среднее геометрическое модулей этих чисел с округлением до 5 знаков после запятой}

end.

 

Ответить

Читайте также

Даны два числа. Найти

среднее арифметическое кубов этих чисел.

1)Найдите ошибки в программах:

a) Program Ошибки1;
Begin
Summa:=6+8;
End;
b) Program Ошибки2;
Begin
Var X:integer;
X:=6+8;
Write(X);
End;




2)Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.
ДАННУЮ ПРОГРАММУ НУЖНО НАПИСАТЬ В ПАСКАЛЕ.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.



Вы находитесь на странице вопроса "Даны 2 числа.Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.