Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1)Найдите ошибки в программах:

10-11 класс

a) Program Ошибки1;
Begin
Summa:=6+8;
End;
b) Program Ошибки2;
Begin
Var X:integer;
X:=6+8;
Write(X);
End;




2)Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.
ДАННУЮ ПРОГРАММУ НУЖНО НАПИСАТЬ В ПАСКАЛЕ.

Gidetuibcsgdh86 13 апр. 2014 г., 1:25:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irinapyatova
13 апр. 2014 г., 3:49:11 (10 лет назад)

Первое задание:
а)Не описана переменная
б)Описание переменных должно быть перед бегином

Ответить

Другие вопросы из категории

Напишите программу(Паскаль), которая считывает с клавиатуры вещественное число Х и выдает на экран значение выражения 1\Х. Очевидно значение х=0 является

недопустимым. Для проверки вводимых с клавиатуры данных воспользуйтесь оператором REPEAT :ссс

Помогите с решением, спасибо.

1. При подключении к Интернету модем обеспечивает
скорость передачи данных, равную 28

Значения элементов двумерного массива А были равны 0 . Затем значения некоторых элементов были изменены (см. представленный фрагмент программы).

n := 0
for i :=1 to 5 do
for j:=1 to 6-i begin
n := n + 1;
A [ i , j ] :=n;
end;
Какой элемент массива будет иметь в результате максимальное значение?
1)A[ 1 ,1 ] 2)A[ 1 , 5 ] 3)A[ 5, 1 ] 4)A [5 , 5 ]




Читайте также

1. Запишите следующее выражение по правилам программирования:



2. Выпишите недопустимые имена переменных:

a) Nomer;
b) S34;
c) И92;
d) Kol_vo54;
e) 45_A;
i) fg-л23

3. Установите соответствие (с помощью стрелок) между переменной и типом данных:

а) A:=3.234 а) Integer
b) Z:=14 b) Real
c) B:=10351 c) Byte
d) K:=-0.2 d) Word
e) C:= 64000

4. Запишите инструкцию:

а) присваивающую переменной V значение 7;

б) увеличивающую значение переменной Z на 30;

в) вычисляющую значение переменной R по формуле (X2+Y2):2;

5. Опишите переменные, необходимые для вычисления:


при x=-5.3, y=7.42

6. Напишите инструкцию вывода на экран:
а) вашего имени б) числа 400 в) значения выражения 7,3(3,22+8,61)

7. Определите, какое значение примет переменная С в результате выполнения данной последовательности операторов присваивания:

a:=8; b:=a/2; c:=43 mod a; a:=(b+c) div 6; b:=b+1; c:=sqrt(abs(a*b-14));

8. Установите соответствие между служебными словами и названиями разделов программы:

а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей

9. Найдите ошибки в записях оператора:

a) Write ©;
b) Writeln;
c) Writeln (Введите любое число);
d) Write X,Y;
e) WRITELN (‘воскресенье, нерабочий день’);

10. Какая структура программы верная:

begin
program MyFirst;
X:=Y+195;
end.


program MyProg;
begin
Writeln (‘Привет’);
end.

11. Расположите в правильном порядке строки программы, вычисляющей периметр и площадь параллелограмма:

1) S:=a*h;

6) var a,b,h,p,s: integer;

2) end.

7) readln;

3) program pr;

8) Writeln(‘p=’,p,’ s=’,s);

4) p:=2*(a+b);

9) a:=6;b:=3;h:=4;

5) Uses crt;

10) clrscr;

11) begin

12. Дан текст программы в таблице с ошибками:

исправьте ошибки в программе;что выведется на экран в результате выполнения программы?

Программа с ошибками

Программа без ошибок

На экране будет напечатано:

War: a,b,c – integer, x: real;
Bigin
A=7, b=3,2, c:=a+b;
Writln (summa=, c);
C:=c/2; x:=a-c;
Writeln(‘x=’ , x, ‘kvadrat=’, x*x);
and

13. Перевести блок-схему на язык Паскаль.

Вычисление расстояния между точками А и B.



30 пунктов!!!Паскль.найдите ошибку и объясните, пожалуйста!!умоляю, ребят!

Подсказка: ошибка связана с "writeln"

Помогите найти ошибки в программе Program Oshibka;

Var a:b;c:Integer;
Begin
Writeln('Введите число ',a);
Readln('a')
b=5
c:=ab;
Writeln('произведение a и b'равно',S);
Readln(a);
End

Исправить ситаксические ошибки в программе которая в тексте меняет слово 77777 на слово 00000 Var s: string; d,i:integer;

begin

s:='177777277777377777477777;

d:=length(s);

for i:=0 to d - 4 begin

if copy(s,i,5)=00000 then begin

delete(s,i,5);

end

end;

writeln(s)

end.

Найдите ошибку,ибо выдает он всегда,что спортсмен не проходит,даже если сумма 100,а общее количество 60.!!!

В массиве хранится информация о баллах,
полученных спортсменом-десятиборцем в каждом из десяти видов спорта. Для выхода
в следующий этап соревнований общая сумма баллов должна превысить некоторое
известное значение. Определить вышел ли данный спортсмен в следующий этап
соревнований.



Вы находитесь на странице вопроса "1)Найдите ошибки в программах:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.