Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны 3 числа - a, b, c . Упорядочить их по возростанию. Плииз решите

5-9 класс

дэвка 13 мая 2013 г., 18:27:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ВасилийГрачёв
13 мая 2013 г., 21:11:02 (10 лет назад)

var a:array [1..100] of real;
i,j,n:integer;
t:real;
Begin
    n:=3;
    for i := 1 to n do
        read(a[i]);

    for i:=1 to n-1 do
      for j:=i+1 to n do
        if a[i]<a[j] then begin
           t:=a[i];
           a[i]:=a[j];
           a[j]:=t;
        end;

    for i:= 1 to n do
        write(a[i],'' );
End.

 

универсальный метод через массивы. сейчас работает для трех элементов

Ответить

Другие вопросы из категории

Читайте также

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "Даны 3 числа - a, b, c . Упорядочить их по возростанию. Плииз решите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.