Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найти пириметр треугольника заданного координатами своих вершин.Определить функции для расчета длины отрезка по координатам ёё вершин.

10-11 класс

Yanaeyrih 04 авг. 2013 г., 9:12:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fater
04 авг. 2013 г., 11:59:32 (10 лет назад)

var
x1, x2, x3, y1, y2, y3, p: real;

function len(x1, y1, x2, y2: real): real;
begin
len := sqrt(sqr(x2 - x1) + sqr(y2 - y1));
end;

begin
readln(x1, y1, x2, y2, x3, y3);
p := len(x1, y1, x2, y2) + len(x1, y1, x3, y3) + len(x2, y2, x3, y3);
writeln(p:8:3);
end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста, написать программы!)

Заполнить массив из 15 элементов случайным образом:
1. вещественными значениями x (22<x<23)
2. вещественными значениями x (0<x<10)
3. вещественными значениями x (-50<x<50)
4. вещественными значениями, лежащими в диапазоне от 0 до 1

Вычитание двоичных чисел.

а) 11011-110=?
б) 10001-1110=?

Система DNS предназначена для:

1.обеспечения маршрутизации коммутационных пакетов
2.обеспечения устойчивости работы сети
3.преобразования числовых IP-адресов в буквенные
4.преобразования буквенных адресов в числовые

Читайте также

Помогите написать програму на С++ Получить все шестизначные счастливые

номера. Счастливым называют такое шестизначное число, в котором сумма его первых трех цифр равна сумме его последних трех цифр. (Определить функцию для расчета суммы цифр трехзначного числа.)

написать программу на паскале Треугольник задан координатами (x1, y1), (x2, y2), (x3, y3)

своих вершин. Вычислить радиус окружности, вписанной в треугольник

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.

Помогите составить программу, пожалуйста, нужно очень срочно! Пятиугольник ABCDE задан координатами своих вершин

(X1,Y1)(X2,Y2)(X3,Y3)(X4,Y4)(X5,Y5) соответственно. Найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию



Вы находитесь на странице вопроса "Найти пириметр треугольника заданного координатами своих вершин.Определить функции для расчета длины отрезка по координатам ёё вершин.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.