Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите составить программу, пожалуйста, нужно очень срочно! Пятиугольник ABCDE задан координатами своих вершин

10-11 класс

(X1,Y1)(X2,Y2)(X3,Y3)(X4,Y4)(X5,Y5) соответственно. Найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию

GAmEoVeR271 06 июня 2013 г., 7:34:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
дашуська5
06 июня 2013 г., 9:49:33 (10 лет назад)

#include <iostream>

using namespace std;

 

struct my{

   int x;

   int y;

}

 

void S_size() ;

 

int main()

{
   my my_struct = new my[5];

   for(int i =0 ;i<5;i++)

{

  cin >> my_struct[i].x;

  cin >> my_struct[i].y;

 

S_size();

}

 

S_size()

{

  double S = 0.5*((my_struct[0].x*my_struct[1].y)-(my_struct[1].x *my_struct[0].y))*((my_struct[1].x * my_struct[2].y)-(my_struct[2].x*my_struct[1].y))*((my_struct[2].x * my_struct[3].y)-(my_struct[3].x*my_struct[2].y))*((my_struct[3].x * my_struct[4].y)- (my_struct[4].x*my_struct[3].y));

cout << S ;

}

Ответить

Другие вопросы из категории

Помогите пожалуйста!

Задание 02

Помогите, пожалуйста, решить задачу в Паскале (программа выводит не правильный результат, а понять где допущены ошибки не могу).

Задать массив из 30 положительных элементов случайным образом.
• найти кол-во нечётных элементов всего массива;
• найти минимальный элемент;
• элементы, кратные 10, заменить единицами и вывести новый массив.

Читайте также

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.

Помогите составить программу для вычисления значения функции y для заданного значения x

у= если x<-3 то
y= √1 - x²
если 1,5<x-3, то
y= в числителе 1 в знаменателе модуль x +2
если x>1,5, то
y=tg x
Составить словесное описание алгоритма, составить блок схему, описать используемые элементы

составить программу

чтобы удалить все гласные из строки , помогите пожалуйста,очень срочно нужно!!!!!!



Вы находитесь на странице вопроса "Помогите составить программу, пожалуйста, нужно очень срочно! Пятиугольник ABCDE задан координатами своих вершин", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.