Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Выяснить, делится ли одно натуральное число на другое без остатка, используя операцию вычитания

10-11 класс

Ojonoshi 01 апр. 2017 г., 9:26:36 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hfw
01 апр. 2017 г., 10:09:23 (7 лет назад)

program minus;

var a,b:integer;

begin

read(a, b);

while ((a <> 0) and (a >= b))

begin

dec(a,b);

end;

if (c=0) writeln('делится') else writeln('не делится');

readln;

end.

 

Если это конечно задача паскаля

Ответить

Другие вопросы из категории

Помогите плиз))

Алгоритм вычисления значения функции

Помогите решить задачу в системе паскаля, фото задачи по ссылке

http://cs309224.vk.me/v309224156/5a57/fT3rlMe9o9k.jpg

Упростить выражение А∨(А∧B)
ОООЧЕНЬ НУЖНА ПОМОЩЬ! НУЖНО НАПИСАТЬ ПРОГРАММЫ (ХОТЯ БЫ ДВЕ,ПОЖАЛУЙСТА) В ПАСКАЛЕ ABC! 1. Дан массив. Все элементы уменьшить на число a.

2. Дан массив целых чисел. Верно ли,что сумма элементов массива есть четное число.

3. В массиве хранятся сведения о количестве осадков,выпавших за каждый день января. Определить общеее количество осадков за месяц и среднее количество за день.

Читайте также

Автоматическое устройство имеет 2 кнопки и экран. При включении на экране загорается число 0. При нажатии на одну кнопку число на экране удваивается (вмест

о x появляется 2x). При нажатии на другую кнопку число увеличивается на 1 (вместо x появляется x+1). Как надо нажимать на кнопки, чтобы на экране появилось
a) Число 5
b) Число 99
c) Число 99,если разрешается нажимать на кнопки не более 10 раз?

Рассмотрим алгоритм, преобразующий одно целое число в другое.

A. Умножить текущее число на 2.
B. Прибавить к результату 1.
C. Если получившееся число больше или равно 17, вычесть из него 17.
Какое получится число, если повторить этот алгоритм 7 раз для исходного
числа 4?
1) 9
2) 10
3) 13
4) 4

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.



Вы находитесь на странице вопроса "Выяснить, делится ли одно натуральное число на другое без остатка, используя операцию вычитания", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.