Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1.

10-11 класс

Дан
одномерный массив а(n), в кото­ром находится единственный эле­мент ,значение
которого принадлежит интервалу от 2 до 5. Найти где он нахо­дится , и
упорядочить по убыванию эле­менты, расположенные перед ним. Вы­дать на экран
номер элемента и упорядо­ченный массив.

денис56выдрие 06 окт. 2013 г., 19:35:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Stesha17
06 окт. 2013 г., 21:32:25 (10 лет назад)

const n=5;
var a:array[1..n] of integer; i,l:integer; t:boolean;
begin
for i:=1 to n do read(a[i]);
for i:=1 to n do if (a[i]>=2) and (a[i]<=5) then begin l:=i; break end;
t:=true;
while t do begin
t:=false;
for i:=1 to l-2 do if a[i]<a[i+1] then begin t:=true; a[i]:=a[i]+a[i+1]; a[i+1]:=a[i]-a[i+1]; a[i]:=a[i]-a[i+1] end
end;
writeln(l);
for i:=1 to n do write(a[i],' ')
end.

Ответить

Другие вопросы из категории

Найдите в литературе или в Интернете характеристики современных микропроцессоров,устройств статической и динамической памяти,внешних запоминающих

устройств,устройств отображения информации (вывода) и сравните их с аналогичными характеристиками устройств первых ЭВМ.

выполнить преобразование шестнадцатеричного числа в двоичное

каждую 16ю цифру представить соответствующими четырьмя двоичными цифрами
2АЕ9 и 22В1

Укажите минимальный объем памяти (в килобайтах), достаточный для хранения любого растрового изображения размером 256x256 пикселей, если известно, что в

изображении используется палитра из 216 цветов. Саму палитру хранить не нужно.

Читайте также



Вы находитесь на странице вопроса "1.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.