Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Переставить в исходном четырёхзначном числе первые две цифры и последние две цифры местами.Например: Входное 1234, выходное 3412. (что тут делать)?

5-9 класс

Vfvf4 01 янв. 2015 г., 23:47:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
8901492
02 янв. 2015 г., 1:42:29 (9 лет назад)

uses crt;
var n,k,a,b:string;
begin
write('Введите четырёхзначное число: ');
readln(a);
n:=copy(a,1,2);
k:=copy(a,3,2);
b:=k+n;
writeln(b);
end.

+ 0 -
Ноточка
02 янв. 2015 г., 3:41:13 (9 лет назад)

var
    s: string;

begin
    read(s);
    if length(s) >= 4 then  
        writeln(s[3] + s[4] + s[1] + s[2]);
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПЛИИИЗ

В таблице записаны названия 18 компьютерных клавиш

Помогите сослать программу на Паскале.Поиск чисел в массиве. Program Example;

{Программа заполняет массив Rand случайными числами в диапазоне от 0 до 50,
вводит число Х, и вычисляет, сколько раз Х входит в массив Rand}

Var Rand: array[1..20] of integer;
I, X, NumberX : integer,
Begin
{Установка датчика случайных чисел}
​Randomize;
{Заполнение массива случайными числами и вывод их на экран}
​Writeln(‘Массив случайных чисел:’)
​For I:=1 to 10 do
​begin
​ Rand[I]:=random(50); Write(Rand[I]:4)
​End;
​Writeln;
{Ввод Х}
​Write(‘Введите Х:’)); Readln(X);
{Подсчет числа вхождений Х в массив}
​NumberX:=0;
​For I:=1 to 10 do
​​If Rand(I)=X then NumberX:=NumberX+1;
{Анализ и вывод результата}
​If NumberX=0
​Then​writeln(‘В массиве нет числа’,X)
​Else writeln(‘Число’,X,’в массиве присутствует’,NumberX,’раза’)
End.

Читайте также

Номер 4

Для всех 4х разрядных чисел найти все симметричные числа,т.е. Числа,у которых первые две цифры и последние две цифры равны

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

Проверочная работа<Линейные алгоритмы>

Составить программы для вычисления:

a) Среднего арифметического кубов двух целых чисел m и n.

Ответ дать с точность до трёх знаков после запятой.

б) Дано четырёхзначное число. Найти остаток от деления чисел образованных первыми двумя цифрами и последними двумя цифрами этого числа

Напишите программу на паскале)

1.С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.
2.С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.
3.С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.



Вы находитесь на странице вопроса "Переставить в исходном четырёхзначном числе первые две цифры и последние две цифры местами.Например: Входное 1234, выходное 3412. (что тут делать)?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.