Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить задачу, очень срочно !!!

5-9 класс

Дан произвольный треугольник ABC, для которого определен следующий набор характерных параметров: a,b,c - стороны треугольника, альфа, бета, гамма - углы (в градусах), h - высота, опущенная на сторону c, S - площадь, P - периметр треугольника. По трем заданным параметрам вычислить все остальные возможные сочетания параметров: а, b, S. Записать в паскале.

Кристи393 23 янв. 2015 г., 2:41:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lizatwix
23 янв. 2015 г., 3:18:18 (9 лет назад)

var
  a, b, S, c, alpha, betta, gamma, H, P: real;
  x, ar, br, gr: real;{alpha, beta. gamma в радианах}

begin
  write('Введите длины двух сторон треугольника и площадь: ');
  readln(a, b, S);
  x := 2 * S / (a * b);
  if x > 1 then writeln('Такой треугольник невозможен')
  else
  begin
    gr := ArcSin(x);
    c := Sqrt(Sqr(a) + Sqr(b) - 2 * a * b * Cos(gr));
    P := a + b + c;
    ar := ArcSin(a * Sin(gr) / c);
    br := Pi - (ar + gr);
    H := b * Sin(ar);
    alpha := ar * 180 / Pi;
    betta := br * 180 / Pi;
    gamma := 180 - (alpha + betta);
    writeln('Решение треугольника');
    writeln('a=', a, ', b=', b, ', c=', c:0:5);
    writeln('Alpha=', alpha:0:2, ', Betta=', betta:0:2, ', Gamma=', gamma:0:2);
    writeln('P=', P:0:5, ', H=', H:0:5, ', S=', S)
  end
end.

Тестовое решение:

Введите длины двух сторон треугольника и площадь: 3 4 6
Решение треугольника
a=3, b=4, c=5.00000
Alpha=36.87, Betta=53.13, Gamma=90.00
P=12.00000, H=2.40000, S=6


+ 0 -
Yale
23 янв. 2015 г., 4:55:12 (9 лет назад)

Комментарий удален

+ 0 -
Chicha199715
23 янв. 2015 г., 6:58:13 (9 лет назад)

да

+ 0 -
Galenik86
23 янв. 2015 г., 7:42:57 (9 лет назад)

там по ходу остальные формулы надо выводить

+ 0 -
Nakhbarovaleyla
23 янв. 2015 г., 8:27:44 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

Помогите решить задачу!!!!

Очень нужно)
Задача 11!!!!!))))

ПОМОГИТЕ ПЛИЗ ЭТО ОЧЕНЬ НАДО СРОЧНО! Привет всем.помогите решить задачу. Как разделить 8 литров подсолнечного масла на две равные части по 4 литра,если

кроме полного 8-литрового бидона есть два пустых бидона на 5 литров и 3 литра. Ответ должен быть не больше семи переливов.



Вы находитесь на странице вопроса "Помогите решить задачу, очень срочно !!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.