Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

даны четыре слова одинаковой длины. напечатать сообщение о наличии или отсутствии одинаковых слов и это слово( в программе pascal)

10-11 класс

Shevchukova 25 февр. 2015 г., 2:46:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1снежинка
25 февр. 2015 г., 4:12:15 (9 лет назад)

var
s1,s2,s3,s4:string;
k:integer;
begin
  writeln('Введите 1 слово:');
  readln(s1);
  writeln('Введите 2 слово:');
  readln(s2);
  writeln('Введите 3 слово:');
  readln(s3);
  writeln('Введите 4 слово:');
  readln(s4);
  writeln('Список одинаковых слов');
  if (s1=s2)or(s1=s3)or(s1=s4) then begin k:=1; writeln(s1); end;
  if (s2=s3)or(s2=s4) then begin k:=1; writeln(s2); end;
  if  s3=s4 then begin k:=1; writeln(s3); end;
  if k=0 then writeln('Одинаковых слов нет');
end.

Ответить

Другие вопросы из категории

вычислить на pascal : 1+2+4+8+...+2^10
хелп...спасите помогите..нужна срочно помощь.. с информатикой:

Создайте Web-страницу, которая выведет список изучаемых предметов. Каждый элемент списка будет ссылкой на другой файл (находящийся в той же, где и сама страница, директории), содержащий информацию о соответствующем предмете.

Читайте также

тест 7 леких вопросов с выбором ответа

13. Тактовая частота процессора – это:

A. число двоичных операций, совершаемых процессором в единицу времени

B. число вырабатываемых за одну секунду импульсов, синхронизирующих работу узлов компьютера

C. число возможных обращений процессора к оперативной памяти в единицу времени

D. скорость обмена информацией между процессором и устройствами ввода/вывода

14.Укажите минимально необходимый набор устройств, предназначенных для работы компьютера:

A. принтер, системный блок, клавиатура

B. процессор, ОЗУ, монитор, клавиатура

C. процессор , стриммер, винчестер

D. монитор, системный блок, клавиатура

15. Что такое микропроцессор?

A. интегральная микросхема, которая выполняет поступающие на ее вход команды и управляет

работой компьютера

B. устройство для хранения тех данных, которые часто используются в работе

C. устройство для вывода текстовой или графической информации

D. устройство для вывода алфавитно-цифровых данных

16.Взаимодействие пользователя с программной средой осуществляется с помощью:

A. операционной системы

B. файловой системы

C. приложения

D. файлового менеджера

17.Непосредственное управление программными средствами пользователь может осуществлять с

помощью:

A. операционной системы

B. графического интерфейса

C. пользовательского интерфейса

D. файлового менеджера

18. Способы хранения данных на физическом носителе определяет:

A. операционная система

B. прикладное программное обеспечение

C. файловая система

D. файловый менеджер

19. Графическая среда, на которой отображаются объекты и элементы управления системы Windows,

созданная для удобства пользователя:

A. аппаратный интерфейс

B. пользовательский интерфейс

C. рабочий стол

D. программный интерфейс

20. Скорость работы компьютера зависит от:

A. тактовой частоты процессора

B. наличия или отсутствия подключенного принтера

C. организации интерфейса операционной системы

D. объема внешнего запоминающего устройства

для обмена сообщениями используют последовательности символов одинаковой длины состоящие из символов "А" и "В" какова должна быть минимальная длина этих

последовательностей, чтобы каждая из них кодировала любое из 50 различных сообщений?
пожалуйста с решением!

1.Алфавит состоит из 25 букв, какое количество информации несет в себе одна буква такого алфавита?

2.Какова длина слова, если при словарном запасе в 256 слов одинаковой длины каждая буква алфавита несет в себе 2 бита информации?



Вы находитесь на странице вопроса "даны четыре слова одинаковой длины. напечатать сообщение о наличии или отсутствии одинаковых слов и это слово( в программе pascal)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.