Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

вычислить на pascal : 1+2+4+8+...+2^10

10-11 класс

Killlll 04 янв. 2015 г., 19:45:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ananieva564
04 янв. 2015 г., 20:18:47 (9 лет назад)

var
  i: integer;

begin
  for k: byte := 0 to 10 do
    i += round(power(2, k));
  writeln(i);
end.

Ответить

Другие вопросы из категории

хелп...спасите помогите..нужна срочно помощь.. с информатикой:

Создайте Web-страницу, которая выведет список изучаемых предметов. Каждый элемент списка будет ссылкой на другой файл (находящийся в той же, где и сама страница, директории), содержащий информацию о соответствующем предмете.

Написать программу (и желательно блок схему) для задачи:

Ввести 10 чисел, и вывести на экран наименьшее.

Дан прямоугольник с размерами 425Х131. От него отрезают квадраты со стороной 131, пока это возможно. Затем от оставшегося прямоугольника вновь отрезают

квадраты со стороной, равной 425-131*3=32, и т.д. На какие квадраты и в каком их количестве будет разрезан исходный прямоугольник?

Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Методом половинного деления вычислить на ЭВМ корень уравнения вида f (x) = 0, расположенный на интервале [a, b] с заданной погрешностью.

Определить число итераций, необходимое для нахождения корня.
3sin√x+0,35x-3,8=0 [2;3] 10^(-3)
НУЖНО ПРЯМ ПРОГРАММУ(

Код программы "Тест" на Pascal

Необходимо написать код программы в формате .txt , чтобы на экране выводилось следующее:

1. Выводится текст "Вам предлагается тест на тему "Поведение в кабинете информатики""

2. Выводится вопрос и несколько вариантов ответа.

3. Выводится "Выберите № ответа".

4. Вопросов всего 3.

5. Выводится "Тест окончен".

6. Выводится "Оценка: Зачет" или "Оценка: Незачет"

Вот сами вопросы:
1. На каком расстоянии от монитора должен
работать ученик за компьютером?

a) 15-20 см

b) 50-70 см

c) Меньше 40 см
d) 90-110 см
2. Можно ли класть тетради, книги, диски на
монитор и клавиатуру?

a) Можно.

b) Можно только на клавиатуру.

c) Можно только на монитор.

d) Нельзя.
3. При появлении запаха гари нужно…

a) Бежать за водой, чтобы предотвратить
дальнейшее возгорание.

b) Прекратить работу, сообщить
преподавателю
c) Не обращать внимания
d) Быстро убежать из кабинета



Вы находитесь на странице вопроса "вычислить на pascal : 1+2+4+8+...+2^10", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.