Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль. дано натуральное 9тизначное число N. Вывести на экран последовательность цифр числа, кратных введеной цифре А. (А<>0)

10-11 класс

Abuka2003 06 марта 2017 г., 6:24:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jarbit
06 марта 2017 г., 7:57:46 (7 лет назад)

var
n:longint;
a:integer;
begin
write ('N = ');readln(n);
write ('A = ');readln(a);
while n <> 0 do begin
if (n mod 10) mod a = 0 then write (n mod 10,' ');
n:=n div 10;
end;
readln;
end.

+ 0 -
1211111111111111
06 марта 2017 г., 8:32:52 (7 лет назад)

uses crt;
var
  a,n,t:integer;
begin
  write('Введите девятизначное число: '); read(N);
  write('Введите число: '); read(A);

  if (A<>0) then 

  begin
  while N>=1 do
  begin
    t:=N mod 10;
    if (t mod A=0) and (t<>0) then writeln(t);
    N:=N div 10;
  end;

  end

  else write('ERROR!');
end.

Ответить

Другие вопросы из категории

1. В корзине лежат

грибы: 30 рыжиков и 18 лисичек. Какие из высказываний будут ИСТИННЫМИ?

Какой объем в памяти компьютера за­нимают предложения:

а) Повторение — мать учения! (Ответ: байт);

б)Миру — мир! (Ответ: бит);

в)Я учусь в 9 классе. (Ответ: байт).

Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и

справа.
У Азизхана есть строка S. Его интересует сколько есть подстрок четной длины у строки S, которые являются палиндромами. Одинаковые подстроки начинающие с разных позиций считаются разными.
Формат входных данных
Единственная строка входного файла содержит одну строку S состоящее из строчных букв английского алфавита (1 <= длина S <= 100000).
Формат выходных данных
Выведите ответ к задаче.

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Даны действительные числа x, y. Вывести на экран то из них, которое меньше.

Даны два символа (латинские буквы). Вывести их на экран в порядке возрастания по алфавиту.

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива



Вы находитесь на странице вопроса "Паскаль. дано натуральное 9тизначное число N. Вывести на экран последовательность цифр числа, кратных введеной цифре А. (А&lt;&gt;0)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.