Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

5-9 класс

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.

Alexandra1706 20 сент. 2013 г., 13:48:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
СууРииКаТиК
20 сент. 2013 г., 15:40:09 (10 лет назад)

min і max нужно присвоить а[1].

+ 0 -
Eminem36
20 сент. 2013 г., 18:01:40 (10 лет назад)

...

writeln('a[',i,']=',a[i]);

readln;

end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ОТВЕТИТЬ

Документ, закодированный 8-и битным кодом(КОИ-8) занимает 120 кбайт.Сколько страниц в документе, если на каждой странице ровно 40 строк по 48 символов в каждой?

Читайте также

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!



Вы находитесь на странице вопроса "пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.