Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В массиве хранится информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого(дорогого) товара и его индекс

5-9 класс

Rosemary717 30 янв. 2014 г., 23:36:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andersan555
31 янв. 2014 г., 1:57:27 (10 лет назад)

program pr1;uses crt;var a:array[1..20] of integer; i,j,max,ind :integer;begin  max:=a[ 1 ];  for i:=1 to 20 do   begin    writeln('Введите цену(макс 20 товаров)');    readln(a[i])   end;  for i :=2 to 10 do    begin     if a [ i ] > max      then      begin      max:=a [ i ]      ind:=i;      end  end;  writeln('максимальная цена тавара ',a[i],'р. И ег оиндекс в массиве=',ind)end.

+ 0 -
ФроловаАлена
31 янв. 2014 г., 3:01:29 (10 лет назад)

масивв то какой? числа рандомные можно?

Ответить

Другие вопросы из категории

Перевести в КБ 6000байт

Читайте также

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "В массиве хранится информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого(дорогого) товара и его индекс", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.