Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Определить, сколько раз будут выполнены арифметические

5-9 класс

действия внутри begin..end в
приведённом фрагменте программы

Zoya93232 23 сент. 2013 г., 17:48:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маршак228
23 сент. 2013 г., 19:34:38 (10 лет назад)

цикл повторится n раз кажется
ну скажем если n=3 то
i=2 сделает
i=3 сделает тк i<=n+1, а 3 <4
i=4 сделает тк i<=n+1, a 4=4
_____________________
если вопрос сколько арифметических операций
то 2n тк s+i и i+1

Ответить

Другие вопросы из категории

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.

ПОМОГИТЕ ОТВЕТИТЬ

Документ, закодированный 8-и битным кодом(КОИ-8) занимает 120 кбайт.Сколько страниц в документе, если на каждой странице ровно 40 строк по 48 символов в каждой?

Читайте также

Чему будут равны a и b после выполнения ВЫЧИСЛИТЕЛЕМ каждого из следующих алгоритмов? Сколько раз будет выполняться тело цикла в каждом из них?

а) Присвоить а значение -5.
Присвоить b значение -2.
Пока а+b меньше аb, повторять:
присвоить а значение 2а.
Присвоить b значение b+1.
Конец цикла.
б) Присвоить а значение 25.
Присвоить b значение 1.
Пока а-b больше а/b, повторять:
Присвоить а значение а+10.
Присвоить b значение -3b.
Конец цикла.

30.

Дан фрагмент программы (все используемые переменные имеют целый тип данных).
на языке Паскаль​на языке Бейсик
P:=1; A:=1;​P=1: A=1
while P<16 do​WHILE P<16
begin​ A=2*A
A:=2*A; P:=P*A;​ P=P*A
end;​WEND
Определите, сколько раз выполнится тело цикла.
1.3​ 2.4​ 3.бесконечно много раз​ 4.16​ 5.0

• 1В процессе преобразования растрового графического изображения количество цветов уменьшилось с 64 до 8. Во сколько раз уменьшился объем, занимаемый

им в памяти. Контрольная работа по теме «Компьютерная графика» 2 вариант • 2Мультимедиа – это А) получение движущихся изображений на дисплее; Б) прикладная программа для создания и обработки рисунков; В) объединение высококачественного изображения с реалистическим звуком; Г) область информатики, занимающаяся проблемами рисования на ЭВМ. • 3Выберите правильную последовательность этапов развития компьютерной графики: а) Появление графических дисплеев; b) Символьная графика; c) Появление графопостроителей; d) Появление принтера цветной печати. А) a, c, d, b; Б) b, c, a, d; С) b, a, c, d; Г) a, b, d, c. 3. Созданием произвольных рисунков, чертежей занимается А) научная графика; Б) конструкторская графика; В) деловая графика; Г) иллюстративная графика. 4. Какое устройство компьютера осуществляет процесс дискретизации звука? А) звуковая карта; Б) колонки; В) наушники; Г) процессор. 5. Растровое изображение представляет из себя … А)мозаику из очень мелких элементов — пикселей; Б) сочетание примитивов; В) палитру цветов. 6. Точка графического экрана может быть окрашена в один из цветов: красный, зелёный, коричневый, чёрный. Какой объём видеопамяти будет выделен для кодирования каждого пикселя? А) 4 бита; Б) 2 байта; В) 4 байта; Г) 2 бита; Д) 3 бита. 7. Инструментом ГР является: А) Линия; Б) цвет; В) разбрызгиватель; Г) рисунок. 8.Графическим примитивом является: А)линия; Б)ластик; В) копирование; Г)цвет. 9. Для получения 4-х цветного изображения на каждый пиксель необходимо выделить А) 1 байт ; Б) 1 бит; В) 2 байта; Г) 2 бита 10.Дискретный сигнал – это …А) цифровой сигнал; Б) количество измерений, производимых прибором за 1 секунду; В) непрерывно меняющееся со временем значение физической величины; Г) таблица с результатами измерений физической величины в фиксированные моменты времени. 11. При какой частоте дискретизации происходит более точное воспроизведение звука? А) 44,1 кГц; Б) 11 кГц; В) 22 кГц; Г) 8 кГц. 12. Что можно отнести к недостаткам растровой графики по сравнению с векторной? А) Большой объём графических файлов. Б) Фотографическое качество изображения. В) Возможность просмотра изображения на экране графического дисплея. Г) Искажения при масштабировании. 13.Что можно отнести к недостаткам ж\к монитора? А) малый вес; Б) затемнения при изменении угла обзора; В) отсутствие э/м излучения; Г) малый объем. • 14Для кодирования зелёного цвета служит код 1011. Сколько цветов в палитре? • 15Найдите объём записываемого звукового квадроаудиофайла, если запись велась 4 минуты, с использованием 16-битовой глубины кодирования звука и частотой дискретизации 32кГц. • 16Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения? • 17 В процессе преобразования растрового графического файла количество цветов уменьшилось с 512 до 8. Во сколько раз уменьшился информационный объем файла?

Составьте программу, которая определяет, сколько раз встречаются числа x,y, x-y,x+y в последовательности из 50 заданных чисел. Данные с

клавиатурызадаются в таком порядке: x y и 50 чисел. Помогите, пожалуйста, очень надо)

в Паскале 1. Среди четырёхзначных чисел выбрать те, у которых все четыре цифры различны.

2. Дано шестизначное число n. Определить сколько раз в нём повторяется минимальная цифра.



Вы находитесь на странице вопроса "Определить, сколько раз будут выполнены арифметические", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.