Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Введите с клавиатуры целочисленные координаты точки на плоскости (x,y). Выведите '0'

5-9 класс

, если точка совпадает с началом координат, '1', если точка лежит на координатных осях, и '2', если точка не лежит на координатных осях.
ПОМОГИТЕ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Bemmen 13 авг. 2014 г., 17:57:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Knizamova
13 авг. 2014 г., 20:13:10 (9 лет назад)

var
x,y:real;
begin
writeln ('Введите координаты точки (x,y)');
readln (x,y);
if (x=0) and (y=0) then writeln ('0')
else if (x=0) or (y=0) then writeln ('1')
else writeln ('2');
end.

Ответить

Читайте также

Введите с клавиатуры целочисленные координаты точки на плоскости (x,y). Выведите "0", если точка совпадает с началом координат, "1", если точка лежит на

координатных осях, и "2", если точка не лежит на координатных осях.
Пример ввода:
6 0
Пример вывода:
1

Напишите следующую программу. Введите с клавиатуры целое число N. Выведите на экран числа от 1 до N так, чтобы каждое число выводилось столько раз, каково

его значение. Например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6
Написать программу нужно как можно проще в программе PascalABC

P.S решить задачи 1. мальчик может бегать в три раза быстрее,чем ходить .Скорость его ходьбы составляет 4км/ч. Он принял участие в марафонском

забеге, но сошел с дистанции, пробежав X км. Сколько времени он затратил но преодоление этой дистанции?

2.Даны две точки на плоскости (х1 ; у1) и (х2; у2). Необходимо определить какая из точек находится дальше (ближе) от начала коорддинатных осей.

3. Написать программу, распознающую по длинам сторон среди всех треугольников прямоугильные.

4. Определить в вещественном числе количество цифр до запятой.

5. В линейной таблице из 16 элементов все числа хранятся в порядке возврастания. Необходимо все числа в таблице расположить в порядке убывания

На плоскости заданы две точки А с координатами (х1, у1) и В с координатами (х2,у2) Координаты точек вводятся с клавиатуры. Определить какая из точек ближе

к началу координат и вывести на экран соответсвующее сообщение
Составьте пожалуста программу в паскале



Вы находитесь на странице вопроса "Введите с клавиатуры целочисленные координаты точки на плоскости (x,y). Выведите '0'", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.