Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

На плоскости заданы две точки А с координатами (х1, у1) и В с координатами (х2,у2) Координаты точек вводятся с клавиатуры. Определить какая из точек ближе

5-9 класс

к началу координат и вывести на экран соответсвующее сообщение
Составьте пожалуста программу в паскале

MaryKod 29 июля 2014 г., 20:03:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ruslanass
29 июля 2014 г., 21:01:40 (9 лет назад)

program gt;
var x1,x2,y1,y2:real;
begin
readln(x1,y1,x2,y2);
if((x1*x1+y1*y1)>(x2*x2+y2*y2))then writeln('2-точка')else
writeln('1-точка');
end.

Ответить

Другие вопросы из категории

На поле одна из ячеек закрашена черным цветом. Определи сумму, которая должна получиться в этой ячейке, если сложить номера по горизонтали и вертикали.

Номера ячеек пронумерованы от 0 до 9. В каком еще количестве ячеек
получается такая же сумма?

Читайте также

на плоскости заданы 2 точки A и B ( их координаты вводятся с клавиатуры ). Программа должна вывести на экран слово TRUE, если обе точки находятся в одной

четверти плоскости ( в одной квандранте ) и вывести слово FALSE во всех остальных случаях! программу составить в паскаль абц

P.S решить задачи 1. мальчик может бегать в три раза быстрее,чем ходить .Скорость его ходьбы составляет 4км/ч. Он принял участие в марафонском

забеге, но сошел с дистанции, пробежав X км. Сколько времени он затратил но преодоление этой дистанции?

2.Даны две точки на плоскости (х1 ; у1) и (х2; у2). Необходимо определить какая из точек находится дальше (ближе) от начала коорддинатных осей.

3. Написать программу, распознающую по длинам сторон среди всех треугольников прямоугильные.

4. Определить в вещественном числе количество цифр до запятой.

5. В линейной таблице из 16 элементов все числа хранятся в порядке возврастания. Необходимо все числа в таблице расположить в порядке убывания

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Определите,какой из представленных на рисунке кругов соответствует множеству:

а)"европейский город";
б)"город в Англии";
в)"столичный европейский город".



Перечислите города-объекты,являющиеся элементами представленных на рисунке множеств.



Вы находитесь на странице вопроса "На плоскости заданы две точки А с координатами (х1, у1) и В с координатами (х2,у2) Координаты точек вводятся с клавиатуры. Определить какая из точек ближе", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.