Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

на плоскости заданы 2 точки A и B ( их координаты вводятся с клавиатуры ). Программа должна вывести на экран слово TRUE, если обе точки находятся в одной

5-9 класс

четверти плоскости ( в одной квандранте ) и вывести слово FALSE во всех остальных случаях! программу составить в паскаль абц

TanyaKim00 15 июля 2013 г., 10:56:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vefrem
15 июля 2013 г., 11:33:45 (10 лет назад)

var x1, x2, y1, y2: integer;
O: boolean;
begin       
write('X1: ');       
readln(x1);       
write('Y1: ');       
readln(y1);       
write('X2: ');       
readln(x2);       
write('Y2: ');       
readln(y2);       
if (x1 < 0) and (x2 < 0) and (y1 < 0) and (y2 < 0) then O:=true;       
if (x1 < 0) and (x2 < 0) and (y1 > 0) and (y2 > 0) then O:=true;       
if (x1 > 0) and (x2 > 0) and (y1 > 0) and (y2 > 0) then O:=true;       
if (x1 > 0) and (x2 > 0) and (y1 < 0) and (y2 < 0) then O:=true;       
if O = true then write('TRUE')       
else write('FALSE');
end.

Ответить

Другие вопросы из категории

Как добавить к слайдам кнопки действий ?
СРОЧНО!!!ОЧЕЕЕЕНЬ!!!!!! Документ состоит из текстовой и графической информации. Текст

содержит 30 строк по 30 символов в каждой. Размер черно-белого
изображения составляет 120 х 300 точек. Определите информационный
объем этого документа.
1) 36000 байт
2) 675 байт
3) 5400 байт

Привет ребят;)

Помогите с задачей на паскаль:)





Какова будет начальная сумма вклада, чтоб через 5 лет снять в банке 3000 у.е.! (под 8 % годовых)
Буду благодарна
Задачу сделать не с ФОР а с ВАЙЛ!
спасибо:)

Читайте также

На плоскости заданы две точки А с координатами (х1, у1) и В с координатами (х2,у2) Координаты точек вводятся с клавиатуры. Определить какая из точек ближе

к началу координат и вывести на экран соответсвующее сообщение
Составьте пожалуста программу в паскале

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

4. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если

точка принадлежит заштрихованной области
(см. рисунок 4) и «Не принадлежит»
в противном случае. Программа должна иметь дружественный интерфейс. Протестировать
программу для точек (0,0), (1,0), (1.5,1),
(-1,1.5), (-2,-1), (2,-1), (1,-1), (-1,1).

В торговом центре этажи нумеруются так: …, –3, –2, –1, 1, 2, 3, … (то есть нет нулевогоэтажа). Вася спустился на лифте с этажа с номером A на B этажей, а

затем поднялся на лифтена C этажей. Определите, на каком этаже он оказался.Программа получает на вход три целых числа: в первой строке записано число A, вовторой — B, в третьей — С. Число A не равно нулю и не превосходит по модулю 100, числа Bи С — положительные и не превосходят 100. Программа должна вывести одно целое число — номер этажа, на котором оказался Вася

Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью vкилометров в час. На

какой отметке он остановится через t часов?

Программа получает на вход значения v и t. Если v>0, то Вася движется в положительном направлении по МКАД, если же значение v<0, то в отрицательном.

Программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится Вася. C++



Вы находитесь на странице вопроса "на плоскости заданы 2 точки A и B ( их координаты вводятся с клавиатуры ). Программа должна вывести на экран слово TRUE, если обе точки находятся в одной", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.