Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Значения элементов двухмерного массива

10-11 класс

Alisamikh 01 июня 2015 г., 21:25:28 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mound
01 июня 2015 г., 22:46:20 (8 лет назад)

const n=10;

var a:array[1..n,1..n] of integer; i,j,w:integer;

begin

for i:=1 to n do

for j:=1 to n do begin 

a[i,j]:=0;

a[j,i]:=0;

end;

for i:=1 to 5 do

for j:=1 to 4 do begin

a[i,j]:=a[i,j]+5;

if(a[i,j]=10) then w:=w+1;

a[j,i]:=a[j,i]+5;

if(a[j,i]=10) then w:=w+1;

end;

writeln(w, ' элементов массива равны 10');

end.

Ответить

Другие вопросы из категории

Один из часто встречающихся видов списка стек — список, в котором все операции включения и извлечения, сопровождающегося удалением из списка, элементов

выполняются только с одного края. Механизм функционирования стека отражён в его названии «LIFO» (Last In First Out — последним вошёл, первым вышел, подобно патронам в обойме). Следовательно, любой элемент не может быть извлечён и удалён из стека раньше, чем будут извлечены все элементы, помещённые в стек позднее него. Составить программу, реализующую функционирование стека. Стек оформить как массив.

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

Значения элементов двумерного массива А были равны 0 . Затем значения некоторых элементов были изменены (см. представленный фрагмент программы).

n := 0
for i :=1 to 5 do
for j:=1 to 6-i begin
n := n + 1;
A [ i , j ] :=n;
end;
Какой элемент массива будет иметь в результате максимальное значение?
1)A[ 1 ,1 ] 2)A[ 1 , 5 ] 3)A[ 5, 1 ] 4)A [5 , 5 ]






Вы находитесь на странице вопроса "Значения элементов двухмерного массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.