Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Объявить массив размерностью N. Заполнить элементы массива. Распечатать значения элементов массива. Вывести значения в обратном

10-11 класс

порядке.

Вывести значения элементов с четными индексами.

Supfamily 16 июня 2014 г., 14:46:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eliza2308
16 июня 2014 г., 17:36:19 (9 лет назад)

#include<iostream>

using namespace std;
int main(){
int N;
int *arr;
cout << "enter size of arr(enter N) : ";
cin >> N;
arr = new int [N];

for(int i = 1; i <= N;i++)
cin >> arr[i];
cout << "your arr : ";
for(int i = 1; i <= N;i++)
cout << arr[i] << " " ;

cout << "new arr : ";
for(int i = N; i > 0;i--)
cout << arr[i] << " " ;

cout << "new2 arr : ";
for(int i = 1; i <= N;i++)
{
if((i % 2) == 0)
cout << arr[i] << " " ;
}
}

Ответить

Читайте также

Задача 1 Составить программу При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В

массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .

Задача 2

В одномерном массиве , состоящем из n вещественных элементов , вычислить ;

1) минимальный элемент массива;

2)сумму элементов массива , расположенных между первым и последним положительными элементами .

Преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

Дано: массивы R(10),Q(10),P(10). Сформировать массив X(3),где X(1) - сумма элементов массива R, значения которых лежат в интервале [2;4];

X(2) - то же для массива Q;

X(3) - то же для массива P.

Вычисление суммы элементов массива, значения которыхлежит в интервале [2;4], оформить в виде подпрограммы.

PascalABC

Вот такие задачи нам задают.Прошу помощи.Заранее спасибо =)

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.



Вы находитесь на странице вопроса "Объявить массив размерностью N. Заполнить элементы массива. Распечатать значения элементов массива. Вывести значения в обратном", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.