Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти сумму элементов, принадлежащих промежутку от x1 до x2 (x1 и x2 вводятся с клавиатуры). Если таких элементов нет, вывести соответствующее сообщение.

10-11 класс

Bulavinaolga83 10 мая 2014 г., 17:26:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
котя003
10 мая 2014 г., 19:57:33 (10 лет назад)

Для С# код программы будет выглядеть так 
Console.WriteLine("Введите Х1 ");    
int a =Convert.ToInt16( Console.ReadLine());
Console.WriteLine("Введите Х2 ");     
 int b = Convert.ToInt16(Console.ReadLine());   
int c=0; 

 if (b>a)       
 { for (int i = a; i < b - 1; i++) c += i + 1; }   
 else { for (int i = b; i < a - 1; i++) c += i + 1; }

   if (c == 0) Console.WriteLine("Между Х1 и Х2 елементов нету"); else           Console.WriteLine("Сумма елементов между Х1 и Х2 = "+c);                      Console.ReadLine();

Если нужно могу скинуть exe-шный фаил с компилированной программой 

Ответить

Читайте также

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

найти сумму квадратов натуральных чисел от 15 до 25. Создать массив а из десяти целых чисел принадлежащих промежутку [0;25) Вывести полученный массив на

экран. подсчитать k-количество элементов массива значение которых превышает 12 ПОМОГИТЕ СРОЧНО

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Найти сумму элементов, принадлежащих промежутку от x1 до x2 (x1 и x2 вводятся с клавиатуры). Если таких элементов нет, вывести соответствующее сообщение.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.