Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Заполнить массив состоящий из n элементов введенный пользователем в автоматическом режиме .Найти среднее значение элемента массива.И упорядочить

10-11 класс

элементы массива.в паскале.срочно!!

74юлия74 03 дек. 2013 г., 0:18:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ananyevamsamsu
03 дек. 2013 г., 2:26:37 (10 лет назад)

program asldkalsdkas;
var a:array[1..20] of integer;
i,j:integer; c:real;
begin
c:=0;
for i:=1 to 20 do
begin readln(a[i]); c:=c+a[i]; end;
c:=c / 20;writeln(c);
for i:=1 to 19 do
for j:= i+1 to 20 do
if a[i]<a[j] then begin a[i]:=a[i]+a[j]; a[j]:=a[i]-a[j]; a[i]:=a[i]-a[j]; end;
for i:=1 to 20 do writeln(a[i]);
end.

Ответить

Другие вопросы из категории

можно ли записать данную программу используя циклы While и Repeat?Если да то предложите свой вариант.

program 5;
uses crt;
var i,n:integer ; x,y,s,p: real;
begin
x:=4.1; S:=0; P:=1;n:=10;
for i:=1 to n do
begin
s:= s+ ln(sqr(x)+I);
P:= p*(i+4*cos(x+I));
end;
Y:= s+p;
writeln('___x=',x:5:1,'___Y=',y:10:2);
writeln('___s=',s:5:3,'___P=',p:10:2);
end.

Товар стоит a руб. b коп. За него заплатили c руб. d коп. Сколько сдачи требуется получить? Вводятся 4 числа: a, b, c и d. Необходимо вывести 2 числа: e и

f, число рублей и копеек, соответственно. паскаль! помогите пожалуйста, дуб дубом в программировании((((

Помогите решить, пожалуйста!

Даны 6 различных чисел. Определить максимальное из них. (Определить функцию, находящую максимум из двух различных чисел).
Нужно написать программу для Pascal.

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.



Вы находитесь на странице вопроса "Заполнить массив состоящий из n элементов введенный пользователем в автоматическом режиме .Найти среднее значение элемента массива.И упорядочить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.