Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить, пожалуйста!

10-11 класс

Даны 6 различных чисел. Определить максимальное из них. (Определить функцию, находящую максимум из двух различных чисел).
Нужно написать программу для Pascal.

Kostierieva2013 02 авг. 2013 г., 21:44:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Xrunkova
03 авг. 2013 г., 0:13:14 (10 лет назад)

var
  a:array[1..6]of integer;
  i,j,max:integer;

function mx(a,b:integer):integer;
begin
if a>b then result:=a else result:=b;
end;

begin
for i:=1 to 6 do
  begin
  a[i]:=random(20);
  write(a[i]:4);
  end;
writeln;
max:=a[1];
for i:=1 to 6 do
  for j:=i+1 to 6 do
    if mx(a[i],a[j])>max then max:=mx(a[i],a[j]);
writeln('max=',max);    
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста с 2 задачами! 1) Простым числом называется натуральное число p>1, натуральными делителями которого которого являются

только два числа: 1 и P. Определить, является ли введенное с клавиатуры число простым.

2) Дано число n. Верно ли, что это число содержит ровно 3 одинаковых цифры?

последовательность действий для того, чтобы показать выступление в театре

например
1 - снять помещение

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

помогите решить пожалуйста))


Вы находитесь на странице вопроса "Помогите решить, пожалуйста!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.