Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста на всех картинках 11 вариант

10-11 класс

Артур200602 12 авг. 2013 г., 2:25:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bydaev11
12 авг. 2013 г., 4:02:04 (10 лет назад)

1)
Program chik;
const n=30;
var a,b:array[1..30]of real;
l,i:integer;
min:real;
begin
for i:=1 to n do
read(a[i]);
min:=a[1];l:=1;
for i:=2 to n do
if(a[i]<min)then begin
min:=a[i];
l:=i;
end;
for i:=1 to l-1 do
begin
b[i]:=a[i];
write(b[i],' '); 
end;
end. 
2)
Program chik;
const n=20;
var a,b:array[1..30]of real;
l,i:integer;
begin
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if(a[i]=0)then begin
l:=i;
break;
end;
for i:=1 to n do
begin
if(i>l)and(a[i]>0)then a[i]:=a[i]*2;
write(a[i],' '); 
end;
end.
3)
Program chik3;
const n=50;
var a,b:array[1..30]of real;
i:integer;
p:real;
begin
p:=1;
for i:=1 to n do
begin
read(a[i]);
if(a[i]<=2)then p:=p*a[i];
end;
writeln(p); 

Ответить

Другие вопросы из категории

Товар стоит a руб. b коп. За него заплатили c руб. d коп. Сколько сдачи требуется получить? Вводятся 4 числа: a, b, c и d. Необходимо вывести 2 числа: e и

f, число рублей и копеек, соответственно. паскаль! помогите пожалуйста, дуб дубом в программировании((((

Помогите решить, пожалуйста!

Даны 6 различных чисел. Определить максимальное из них. (Определить функцию, находящую максимум из двух различных чисел).
Нужно написать программу для Pascal.

Помогите пожалуйста с 2 задачами! 1) Простым числом называется натуральное число p>1, натуральными делителями которого которого являются

только два числа: 1 и P. Определить, является ли введенное с клавиатуры число простым.

2) Дано число n. Верно ли, что это число содержит ровно 3 одинаковых цифры?

Читайте также

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

помогите пожалуйста на 2 вопроса ответить:

1)В системе счисления с некоторым основанием десятичное число 29 записывается в виде 41.Укажите это основание?
2)Укажите через запятую в порядке возрастания все основания системы счисления,в которых запись числа 24(в десятеричной системе счисления) оканчивается на 4.
Очень буду вам благодарна,заранее спасибо!!!!)



Вы находитесь на странице вопроса "Помогите пожалуйста на всех картинках 11 вариант", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.