Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1. Составьте программу, которая

5-9 класс

вычисляет сред­нюю плотность раствора (в кг/м3) по результатам из­мерения
плотности 7 проб (задаются в массиве кон­стант: 1205, 1350, 1170, 1320, 1220,
1310, 1180).

Hemul561 21 сент. 2013 г., 12:02:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bashcka
21 сент. 2013 г., 13:41:43 (10 лет назад)

program nikitos1515;
const mas:array[1..7] of integer = (1205, 1350, 1170, 1320, 1220, 1310, 1180);
var i:integer;   
sredn:real;
begin
for i:=1 to 7 do
sredn:=sredn+mas[i];
sredn:=sredn/7;
writeln('Средняя плотность раствора =',sredn);
end.

+ 0 -
Danil110173
21 сент. 2013 г., 14:51:41 (10 лет назад)

Если решать с вашими константами:
program test;
uses crt;
var a:array [1..10] of integer;
i: integer;
rez:real;
begin
rez:=0;
a[1]=1205; a[2]=1350; a[3]=1170; a[4]=1320; a[5]=1220; a[6]=1310; a[7]=1180; 
for i:=1 to 7 do
rez:=rez+a[i];
rez:=rez/7;
write('rez = ',rez);
end.

Но, я предлагаю, чтобы пользователь сам вводил 7 значений, это так:
program test;
uses crt;
var a:array [1..10] of integer;
i: integer;
rez:real;
begin
rez:=0;
for i:=1 to 7 do
read(a[i]);
for i:=1 to 7 do
rez:=rez+a[i];
rez:=rez/7;
write('rez = ',rez);
end.

Ответить

Другие вопросы из категории

Вводятся 5 чисел. Определить, сколько среди них целых.

составить алгоритм с циклом с условием

помогите пж, срочно надо
Коля предложил Пете более сложную игру, чем изложенная в задании 40. Коля задумывает натуральное число из интервала от 1 до n. Петя должен это число отг

адать. Он может задавать вопросы коле, допускающие только ответы да или нет. Петя разработал алгоритм, позволяющий за наименьшее число вопросов отгадать число, задуманное Колей. Выясните сколько вопросв потребуется Пете, чтобы отгадать задуманное число , если оно принадлежит интервалу: 1) от 1 до 32 2) от 1 до 512 3) от 1 до 300 4) от 1 до 1024 Плз помогите срочно надо!!!!!!!!!!!!

Задачи на фотографиях

Читайте также

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.



Вы находитесь на странице вопроса "1. Составьте программу, которая", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.