Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]

5-9 класс

Задана продолжительность некоторого события в секундах целым числом. Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.
Входные данные:
Во входном потоке задано единственное натуральное число T (T < 10000000)

Выходные данные:
Вывести три натуральных числа через пробел: часов, минут, секунд

Пример входного файла (input.txt):
3666

Dackosasha 29 нояб. 2014 г., 7:16:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shumirina1973
29 нояб. 2014 г., 8:11:36 (9 лет назад)

var
  f: Text;
  T: longint;
  h, m, s, err: integer;
  c: string;

begin
  Assign(f, 'input.txt');
  Reset(f);
  Readln(f, c);
  Val(c, T, err);
  Close(f);
  h := T div 3600;
  T := T mod 3600;
  m := T div 60;
  s := T mod 60;
  writeln(h, ' ', m, ' ', s)
end.

Тестовое решение:

1 1 6


Ответить

Другие вопросы из категории

Помогите с информатикой плизз

108 байт = ... Кб ...байт
2040 Мб = ... Гб
107 Кб = ... бит
______________________
20 баллов за ответ

Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, как

соотносятся между собой два произвольных числа A и B.

2. Фирма осуществляет набор сотрудников. Условия приема требуют не менее 3 лет рабочего стажа и возраст не более 35 лет. Написать программу, проверяющую, удовлетворяет ли кандидат этим требованиям.

Читайте также

Помогите срочно пожалуйста

Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]
Даны два целых числа. Вывести меньшее из них.
Входные данные:
Во входном потоке в первой строке через пробел заданы целые числа A и B (-30000 < A,B < 30000), A неравно B.

Выходные данные:
В выходной поток вывести единственное целое число.

Пример входного файла (input.txt):
-30000 45
Пример выходного файла (output.txt):
-30000

1. Какие из перечисленных ниже устройств относятся к внешним? Монитор, процессор, оперативная память, принтер, клавиатура, жёст

кий диск, флэш-память, колонки.

2. Компьютер Вани имеет следующие характеристики:

- тактовая частота – 1,7 ГГц,

- объём оперативной памяти – 256 Мбайт.

Ваня хочет приобрести диски с компьютерными играми, на которых указаны следующие системные требования:

Диск 1. Процессор с тактовой частотой 1,5 Ггц, объём ОП – 256 Мбайт

Диск 2. Процессор с тактовой частотой 2 ГГц, объём ОП – 256 Мбайт

Диск 3. Процессор с тактовой частотой 1,7 Ггц, объём ОП – 512 Мбайт

Диск 4. Процессор с тактовой частотой 1,3 Ггц, объём ОП – 128 Мбайт.

Какие из указанных дисков Ване не стоит приобретать и почему?

3. Какова максимальная разрядность современных процессоров?

4. Расположите устройства внешней памяти в порядке убывания их объёма: CD-ROM, жёсткий диск, дискета, DVD-ROM.

5. В чём преимущества использования флэш-памяти перед другими видами внешней памяти?

Когда сломался компьютер, его хозяин сказал: "Оперативная память не могла выйти из строя". Сын хозяина компьютера предположил, что сгорел процессор, а

жесткий диск исправен. Пришедший специалист по обслуживанию сказал, что скорее всего с процессором все впорядке, а оперативная память неисправна. В результате оказалось, что двое из них сказали все верно, а третий все не верно. Что же сломалось?

Проверочная работа по теме

«Аппаратное обеспечение компьютера»

1) Архивный файл может иметь расширение:
a) . xls;
b) .mp3;
c) .bmp;
d) .zip;
e) .doc.

2) Графическим является файл c расширением:
a) .exe;
b) .htm;
c) .xls;
d) .bmp;
e) .doc.

3) Специально написанная программа, которая присоединяется к другим программам и портит software:
a) архиватор;
b) интерпретатор;
c) компьютерный вирус;
d) драйвер;
e) транслятор.

4) Основные компоненты функциональной схемы компьютера:
a) клавиатура, монитор, дисковод, системный блок;
b) устройства ввода-вывода, процессор, внутренняя память, внешняя память;
c) монитор, винчестер, принтер, дисковод;
d) устройства ввода-вывода, арифметико-логическое устройство, устройство управления, оперативная память;
e) клавиатура, мышь, монитор, дисковод, принтер, сканер.

5) Во время исполнения программа находится в:
a) клавиатуре;
b) процессоре;
c) буфере обмена;
d) мониторе;
e) оперативной памяти.

6) Исполняемым является файл c расширением:
a) .xls;
b) .htm;
c) .exe;
d) .bmp;
e) .doc.

7) Архиватор — это программа, предназначенная для:
a) резервного копирования файлов;
b) хранения редко используемых программных файлов;
c) сжатия файлов;
d) защиты от компьютерных вирусов;
e) расширения возможностей ОС.

8) Действие, безвозвратно удаляющее объект Windows:
a) перетащить значок объекта в корзину;
b) выделить объект и нажать клавишу на клавиатуре;
c) в контекстном меню выбранного объекта выполнить команду Удалить;
d) выделить объект и нажать клавишу при нажатой клавише ;
e) выделить объект и выполнить команду меню Файл  Удалить.

9) Укажите, какая информация не является объективной:
a) «На улице холодно»;
b) «У кошки четыре лапы»;
c) «Поезд № 23 отправляется с 3-го пути»;
d) «На улице 22С»;
e) «Париж — столица Франции».

10) Магистрально-модульный принцип архитектуры компьютеров предполагает следующую логическую организацию компонент:
a) каждое устройство связано с другими напрямую;
b) каждое устройство связано с другими через одну центральную магистраль;
c) каждое устройство связано с другими через магистраль, включающую в себя шины данных, адреса и управления;
d) устройства связаны друг с другом в заданной последовательности (кольцо);
e) связь устройств друг с другом через центральный процессор, к которому все подключены.

Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая определяет время

прибытия самолета в аэропорт назначения в виде «чч:мм» Формат входных данных: С клавиатуры вводится четыре числа через пробел НН, ММ, НР, МР, обозначающие соответственно часы и минуты вылета и часы и минуты продолжительности полета. Формат выходных данных: На экран вывести время прибытия самолета в аэропорт назначения в виде «чч:мм



Вы находитесь на странице вопроса "Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.