Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вводится строка текста из N символов,слова разделены одним пробелом.Найти длину самого длинного слова.Написать программу в Паскале.

10-11 класс

Porshuxa 02 янв. 2015 г., 14:07:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
22022001
02 янв. 2015 г., 15:48:44 (9 лет назад)

var
i,k,l:integer;
s:string;
begin
readln(s);
k:=0;
i:=1;
while i<length(s) do
begin
  l:=0;
  while (s[i]<>' ') and (i<length(s)) do
  begin
    l:=l+1;
    i:=i+1;
  end;
  i:=i+1;
  if l>k then k:=l;
end;
writeln(k);
end.

Ответить

Другие вопросы из категории

(C++) Доказано что матрица [Aij], i=1,…10, j=1,…10 может служить ключом шифра, если из элементов Aij, A 10-i+1 j, A i 10-j+1, A 10-i+1 10 –j+1 в точности

один равен нулю. Не могу понять это условие. Помогите пожалуйста

Исполнитель КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера:

Умножь на 2

Прибавь 1

Выполняя команду номер 1, КАЛЬКУЛЯТОР умножает число на экране на 2, а выполняя
команду номер 2, прибавляет к числу на экране 1. Напишите программу, содержащую не
более 5 команд, которая из числа 6 получает число 33. Укажите лишь номера команд.

Например, программа 12122 -это программа:
Умножь на 2

Прибавь 1

Умножь на 2
Прибавь 1
Прибавь 1

которая преобразует число 5 в число 24.

Найти разность двух чисел, записанных в двоичной системе

11100-111=Х
найти Х и записать его в десятичном виде

Читайте также

Дана строка русского текста до 60 символов.Слова разделены пробелами.Заменить встречающиеся в строке слова то на слово это.Напечатать исходную и

полученную строки.Напишите,пожалуйста,программу.Составить программу в паскале.

Два текста на русском языке записаны в различных кодировках. Первый текст состоит из 240 символов и записан в 16-битной кодировке Unicode, второй текст сос

тоит из 120 символов и записан в 8-битной кодировке КОИ-8. Во сколько раз количество информации в первом тексте больше, чем во втором?
1)5 2)2 3)3 4)4

16. Цепочки символов (строки) создаются из букв латинского алфавита по следующему правилу: Первая строка состоит из двух символов – это буквы «AB».

Каждая из последующих цепочек создается такими действиями: в начало записывается буква, следующая по алфавиту за первой, далее записывается предыдущая строка и она же в обратном порядке символов (справа налево). Вот первые 4 строки, созданные по этому правилу:

(1) AB

(2) BABBA

(3) CBABBAABBAB

(4) DCBABBAABBABBABBAABBABC

16.1. С какой буквы начинается 13-я строка?

16.2. Сколько раз буква А встречается в 10-ой строке?

16.3. Какая буква стоит на 8-ой позиции в 11-ой строке?

16.4. Сколько раз встречается буква А в первых семи строках (суммарно)?



Вы находитесь на странице вопроса "Вводится строка текста из N символов,слова разделены одним пробелом.Найти длину самого длинного слова.Написать программу в Паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.