Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Даны три вещественных числа. Вывести на экран те их них, которые принадлежат

1-4 класс

интервалу (1,6 - 3,8).

Bikaeva 06 нояб. 2013 г., 21:10:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Алька899
06 нояб. 2013 г., 23:22:47 (10 лет назад)

#include<iostream>
using namespace std;
int main()
{
float i,a[100];
int n;
cout<<"введите кол-во чисел:";
cin>>n;
cout<<"введите числа:";
for(i=1;i<=n;i++) {cin>>a[i];}
for(i=1;i<=n;i++)
{
if (a[i]>1.6 && a[i]<3.8) {cout<<a[i];}
}
return 0;
}

Ответить

Другие вопросы из категории

помогите плиз!!!

данные - это закодированная и представленная на носителе информация в виде:_______________, _____________, ___________, ____________.

Информатика 4 класс

1) какое устройство преобразует информацию
2) какие носители информации используются для хранения информации в компьютере
3) какие устройство и программу должен иметь компьютер для создания рисунка

Читайте также

Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.

Входные данные:
Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
5 4 5
Пример выходного файла
YES

Даны три вещественных числа x, y, z. Вычислить значения выражений x

+y+z и xyz и вывести максимальное из них

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a ,

b ) .

Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .

Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.

Напишите программу, которая

позволяет ввести три вещественных числа и выводит на экран:


сумму
всех трех чисел;
модуль
разности первого и второго чисел;
целую
часть произведения второго и третьего чисел.


Все вещественные числа должны быть
выведены в форме с фиксированной точкой с двумя знаками после запятой; перед
каждым вычисленным значением должны идти пояснительный текст и выражение.



Вы находитесь на странице вопроса "Даны три вещественных числа. Вывести на экран те их них, которые принадлежат", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.