Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Записать в двоичный файл только не отрицательные элементы массива

10-11 класс

Mariustinova66 02 июля 2013 г., 16:59:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SvetikFilatova
02 июля 2013 г., 19:22:30 (10 лет назад)

const
  n = 20;

var
  T: array[1..n] of integer;
  i, k: integer;
  F: file of integer;

begin
  Randomize;
  k := 0;
  Assign(F, 'out.dat');
  Rewrite(F);
  for i := 1 to n do
  begin
    T[i] := Random(51) - 25;
    if T[i] >= 0 then
    begin
      k := k + 1;
      write(F, T[i])
    end;
  end;
  Close(F);
  writeln('В файл out.dat помещено ', k, ' элементов массива')
end.

Тестовое решение:

В файл out.dat помещено 13 элементов массива


Ответить

Другие вопросы из категории

Была произведена серия из 12 подбрасываний монетки. В результате каждого подбрасывания монетка может выпасть орлом или решкой с равной вероятностью.

Сколько бит информации будет нести в себе сообщение о том, что в этой серии было только пять выпадения монетки орлом, и все они следовали строго подряд. В ответе укажите целое число.

Помогите с пожалуйста, ребят )

Читайте также

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

Есть текст программы. Вроде работает, но не выдает результат. Нужно исправить ошибку. Кидаю файл с программой. В паскале.

А вот само задание:
Дано: массивы А(8),
В(10). Сформировать массивы C
и D:
массив С должен состоять только из положительных элементов массива А и В, а
массив D
из отрицательных. Предусмотреть подсчет и печать количества отрицательных и
положительных элементов в каждом из массивов А и В. Подсчет и печать количества
отрицательных и положительных элементов массива оформить в виде подпрограммы.

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.



Вы находитесь на странице вопроса "Записать в двоичный файл только не отрицательные элементы массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.