Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан массив ТОЛЬКО из отрицательных элементов. Как найти наибольший элемент этого массива (тот, что максимально приближен к нулю)?

10-11 класс

Условие типа, a[i]>max не идет,всегда max=0

Mahmood 05 янв. 2014 г., 22:55:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Safarovdg
06 янв. 2014 г., 1:54:10 (10 лет назад)

m=a[0];
for (i=0;i<poslednee;i++)
     if (a[i] > m) m=a[i];

+ 0 -
No228
06 янв. 2014 г., 4:18:47 (10 лет назад)

Pascal ABC

Ответить

Другие вопросы из категории

Аня пригласила свою подругу Наташу в гости, но не сказала ей код от цифрового замка своего подъезда, а послала следующее сообщение: «В

последовательности 4, 1, 9, 3, 6, 9 из всех чисел, которые больше 4, разделить 3, а затем удалить из полученной последовательности все четные числа».

Выполнив указанные в сообщении действия, Наташа получила следующий код для цифрового замка:

1)1313

2)133

3)1333

4)432

срочно решите пожалуйста!

Читайте также

Дан двумерный массив m*n , заполните его числами, найти наибольший элемент в каждой строке, вывести его значения и координаты.

Решить в Pascal. Перед тем как выкладывать ответ, проверьте решение.

Дан массив, состоящий из 100 целых чисел:

а) Вывести все числа, которые встречаются в этом массиве по нескольку раз;
б) Вывести все числа, которые встречаются в массиве только по одному разу.

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "Дан массив ТОЛЬКО из отрицательных элементов. Как найти наибольший элемент этого массива (тот, что максимально приближен к нулю)?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.