Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу в Паскале для нахождения суммы чисел 2+4+7+11+16+.......+n

10-11 класс

Срочно!! Спасите!!

T4t345 19 дек. 2016 г., 23:24:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Egdhdjr
20 дек. 2016 г., 1:55:55 (7 лет назад)

var n, s, dob, pres: integer;
begin
     read(n);
     dob := 2; {Разность между очередными слагаемыми}
     pres := 2; {Очередное слагаемое}
     s := 0; {Итоговая сумма}
     while pres <= n do {Т.к. число n может не совпадать ни с каким числом из ряда, то сумма будет подсчитана до ближайшего числа из ряда, не превышающего n}
     begin
          s := s + pres;
          pres := pres + dob;
          dob := dob + 1;
     end;
     writeln(s);
end.

Ответить

Другие вопросы из категории

Читайте также

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 3. Программа получает на вход количество

чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3.Количество чисел не превышает 100. Введённые числа не превышают 300.Программа должна вывести одно число – сумму чисел, оканчивающихся на 3.
Паскаль

помогите решить Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6. Пример работы программы: Входные данные Выходные данные 3 12 25 6 18 20.2

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.



Вы находитесь на странице вопроса "Напишите программу в Паскале для нахождения суммы чисел 2+4+7+11+16+.......+n", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.