Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

РЕШИТЬ В ПАСКАЛЕ СРОЧНО!

10-11 класс

в одномерном массиве М[15] вычислить сумму четных чисел

Dvivhy6 26 мая 2013 г., 0:56:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mrhacker26
26 мая 2013 г., 1:45:06 (10 лет назад)

const
  n = 15;

var
  T: array[1..n] of integer;
  s, i: integer;

begin
  writeln('Введите ', n, ' элементов массива');
  for i := 1 to n do
  begin
    read(T[i]);
    if T[i] mod 2 = 0 then s := s + T[i]
  end;
  writeln(#13#10, 'Введено: ');
  for i := 1 to n do write(T[i]:5);
  writeln(#13#10, 'Сумма четных чисел: ', s);
end.

Тестовое решение:

Введите 15 элементов массива
3 8 12 -4 7 43 0 -3 14 7 -6 14 6 -9 1

Введено:
    3    8   12   -4    7   43    0   -3   14    7   -6   14    6   -9    1
Сумма четных чисел: 44



Ответить

Читайте также

Решить задачу.Паскаль.

Дан двумерный массив.в квадратной матрице заменить все симметричные и равные элементы на нули.Решить с помощью процедур

люди помогите решить задачку(паскаль) очень прошу

оценка за четверть решается моя

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.



Вы находитесь на странице вопроса "РЕШИТЬ В ПАСКАЛЕ СРОЧНО!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.