Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите решить на паскале:Дано трехзначное число. Получить число, в котором цифры стоят в обратном порядке.

10-11 класс

Катюшан 15 февр. 2014 г., 21:34:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shaggydhfjdyjggjq
15 февр. 2014 г., 23:31:53 (10 лет назад)

var a,b,c,n:integer;

begin

  write('n='); read(n);

  a:=n mod 10;

  b:=n div 10 mod 10;

  c:=n div 100;

  write(a);

  write(b);

  write(c);

end.

Ответить

Другие вопросы из категории

Читайте также

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

СРОЧНО ПЛИИИЗ Задача: Дано действительное число Х, вычислить

(x-1)(x-3)(x-7)...(x-63)/(x-2)(x-4)(x-8)...(x-64) (дробь)

Используя оператор: while
Не могу написать через данный оператор программу на паскаль, выходит всегда число 0. Прошу помочь мне :)

дано трехзначное число. найдите сумму его цифр.

решите кодом Паскаля abc.
заранее спасибо

Плиз помогите с информатикой( в башке заело) ( здесь нужно использовать циклы for while или repeat);заранее спасибо)

1)Натуральное число n называется простым если оно делится только на 1 и на само себя.по соглашению 1 не считают простым числом. Проверить является ли n простым числом

2)Найдите и выведите на экран все трехзначные числа кратные 3, сумма цифр которых больше суммы цифр частного от деления их на 3

Исполнитель Черепашка выполняет программу:

для K от 1 до N выполнить
вперёд K
направо 90
кц
Ввести N и определить расстояние между начальным и конечным положением исполнителя.
Помогите решить на паскале



Вы находитесь на странице вопроса "Помогите решить на паскале:Дано трехзначное число. Получить число, в котором цифры стоят в обратном порядке.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.