Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Изменение

10-11 класс

элементов массива

Дан массив из N положительных элементов, больших 1
(2<=N<=100).
После каждого элемента вставить его минимальный делитель
больший 1.



Формат входных данных:

На входе подаются в первой строке N - число элементов массива

Вторая строка содержит N чисел - значения элементов массива



Формат выходных данных: Выведите результирующий массив в строку



Пример:

Ввод

5

43 50 76 84 100



Вывод

43 43 50 2 76 2 84 2 100 2

Kuraaama 14 февр. 2014 г., 23:22:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Altksandronez78
15 февр. 2014 г., 0:14:16 (10 лет назад)

program gt;
label 1,2;
var a,b:array[1..1000]of integer;
n,i,l,j:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
l:=round(sqrt(a[i]));
for j:=2 to l do
begin
if(a[i] mod j=0)then goto 1;
end;
b[i]:=a[i];
goto 2;
1:
b[i]:=j;
2:
end;
for i:=1 to n do
begin
write(a[i],' ',b[i],' ');
end;
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ СРОЧНО!!!!!!!

Web - браузер - это

1. совокупность взаимосвязанных страниц, принадлежащих какому - то одному лицу или организации.

2. сеть документов, связанных между собой гиперссылками.

3.компьютер, на котором работает сервер - программа WWW.

4. клиент - программа WWW, обеспечивающая пользователю доступ к информационным ресурсам интернета.

РЕЖИМ СВЯЗИ С Web - сервером

1. on-line режим.

2. off-line режим

A22 в 16 перевести в 2 чную систему счисления

A22 это сколько?

пропускная способность канала 10 Мбит в секунду . канал подвержен воздействию шума, поэтому избыточность кода передачи составляет 20 %. Определите, за

сколько времени по каналу будет передан текст, информационный объем которого составляет 100 Кбит

Читайте также

Попробуйте внести изменения в блок-схему на рисунке так,чтобы алгоритм учитывал возможность выбора нескольких элементов набора

данных,удовлетворяющих одному и тому же значению критерия поиска.Например позволял решить задачу поиска из задания 3(В журнале успеваемости учащихся со сведениями о годовых оценках требуется осуществить поиск всех отличников по информатике. Что в этой ситуации является набором данных, что- ключом поиска, что- критерием поиска?)Задание 3 не нужно делать.Но нужно главное внести изменения в схему

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз. Если выполняются одновременно 2 условия, то выведите эти числа без изменения. Иначе, выведите разность первого и последнего чисел.
Решить нужно в С или С++
Заранее спасибо!!!

Составить программу вычисления функции на языке паскаль (a+b)/ (e^-x+Sin(x)) T={ (a+b)/(x+1) e^-x+Sin(x) условие:

x<2.8; 2.8<=x<6; x>=6 исходные данные: a=2.1; b=-0.29 шаг изменения: x принадлежит [0;7]; дельта x=0.5

Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия:

а) Четные числа делит на 2 и результат выводит на экран
б) нечетные числа выводит на экран без изменений

HELP ME!! задан массив размерностью (10х10) элементов. присвоить элементам массиваизначение функции Y=cos(x^0.25-0.5x^0.5+0.25x^0.75) при изменении

аргумента от 6 с шагом 0.25.
найти максимальный элемент массива. сформулировать новый массив путем вычеркивания строки и столбца, на которых расположен максимальный элемент.
вывести на экран в формате 3 знака после запятой:
1. исходный массив
2. полученный массив
3. искомые элементы ( если они есть)
предесмотреть возможность вывода на экран и в файл....



Вы находитесь на странице вопроса "Изменение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.