Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана матрица раз мерности NxM. В каждой строке матрицы посчитать количество отрицательных элементов.

10-11 класс

Nast12356 20 сент. 2014 г., 13:51:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ullapopken
20 сент. 2014 г., 14:52:13 (9 лет назад)

uses crt;
var

  a:array [1..100,1..100] of real;
  n,m,k:integer;
begin
  clrscr;
  randomize;
  write('N='); read(n);
  write('M='); read(m);
  for n:=1 to n do
    for m:=1 to m do
      a[n,m]:=random(100)-50;
  for n:=1 to n do
  begin
    for m:=1 to m do
      write(a[n,m],' ');
      writeln;
  end;
  for n:= 1 to n do
  begin
    k:=0;
    for m:= 1 to m do
    begin
       if a[n,m]<0 then
      k:=k+1;
    end;
    writeln('Кол-во отрицательных элементов '

Ответить

Другие вопросы из категории

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

Объяснить значение следующих ключевых понятий :

1)Задача
2)Диалоговое окно
3)Папка "МОЙ КОМПЬЮТЕР"

Читайте также

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

дано массивы A(N1,N1),B(N2,N2),C(N3,N3). найти в каждой строке исходного массива наименьший элемент и переставить его с элементом стоящим на главной

диагонали. нахождение в каждой строке массива наименьшего элемента и его перестановку с элементом стоящим на главной диагонали оформить в виде подпрограммы



Вы находитесь на странице вопроса "Дана матрица раз мерности NxM. В каждой строке матрицы посчитать количество отрицательных элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.