Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана матрица Z(7,3) (элементы ее выбрать самостоятельно). Сформировать массив С, в который войдут минимальные элементы каждой строки матрицы Z. Напечатать

10-11 класс

матрицу и полученный массив.

ДеваС 29 авг. 2013 г., 15:54:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyayakunina
29 авг. 2013 г., 18:04:14 (10 лет назад)

var i, j, min: integer;
     z: array[1..7, 1..3] of integer;
     c: array[1..7] of integer;
begin
  for i := 1 to 7 do begin
    min := 32767;
    for j := 1 to 3 do begin
      z[i, j] := random(20);
      write(z[i, j]:3);
      if(min > z[i, j]) then min := z[i, j];
    end;
    c[i] := min;
    writeln;
  end;
  write(#10, 'Сформированный массив С:');
  for i := 1 to 7 do write(c[i]:3);
end.

Ответить

Другие вопросы из категории

Заполнить массив из 10 элементов случайными числами в интервале [-10..10] и найти в нем два максимальных элемента и их номера.

Пример: Исходный массив: 4 -5 3 10 -4 -6 8 -10 1 0 максимальные a[4]=10, a[7]=8

в чем сходство CD и DVD ? в чем их различие ?

таблица
характеристика СD DVD

различие

Каково

количество кодовых комбинаций символов алфавита, если разрядность
двоичного кода равна 7:

в паскале решите

составьте программу для вычисления значения функции при любом x:y=2+3x/2-4x

Читайте также

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.



Вы находитесь на странице вопроса "Дана матрица Z(7,3) (элементы ее выбрать самостоятельно). Сформировать массив С, в который войдут минимальные элементы каждой строки матрицы Z. Напечатать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.