Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Описать функцию, позволяющую находить наибольший общий делитель двух заданных чисел. помогите плиииииииззз. заранее спасибо.

10-11 класс

Ooolgunchik1 22 сент. 2014 г., 22:52:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karinka2006
23 сент. 2014 г., 0:48:47 (9 лет назад)

var a,b:integer;
begin
writeln ('введи 2 числа');
readln (a,b);
while a<>b do
if a>b then a:=a-b
else b:=b-a;
writeln (a);
end.

Ответить

Другие вопросы из категории

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен фраг­мент про­грам­мы, об­ра­ба­ты­ва­ю­щей

дан­ный мас­сив.

s: = 0;

n : = 10 ;

for i : = 1 to n do

begin

if i = n - i then s : = s + A[i] + A[i + 1];

end;

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лись числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т. е. эле­мент А[0]=0, А[1]=2 и т. д. Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­ной про­грам­мы?


1) 0
2) 11
3) 22
4) 110

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

Читайте также

Для нахождения наибольшего общего делителя двух целых положительных чисел можно применить алгоритм Евклида. Он заключается в следующем: пока

числа не равны, большее число заменяется разностью этих чисел. Полученное в результате число и есть наибольший общий делитель. Какие элементы, пронумерованные от 1 до 5, нужно вставить в блок-схему на места, обозначенные буквами от А до Д, чтобы получившаяся блок-схема соответствовала алгоритму Евклида?

(код паскаль)Написать набор процедур для работы с обыкновенными дробями, обеспечив их сложение, вычитание, умножение, деление. Примечание: обыкновенную

дробь представлять двумя целыми числами: первое число представляет числитель дроби, а второе - знаменатель. В процессе вычислений требуется сокращать дроби на их наибольший общий делитель (НОД). Если одно из чисел равно нулю, то НОД берем равным 1. Разработать также отдельные процедуры для ввода (на экран выводится надпись: «Введите числитель и знаменатель обыкновенной дроби») и вывода обыкновенных дробей (a/b).



Вы находитесь на странице вопроса "Описать функцию, позволяющую находить наибольший общий делитель двух заданных чисел. помогите плиииииииззз. заранее спасибо.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.