Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

с клавиатуры вводятся N произвольных натуральных чисел. найти сумму тех из них в составе которых отсутствуют нечетные цифры

5-9 класс

Karinabeniusyte 07 марта 2017 г., 19:49:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kuro4enko
07 марта 2017 г., 20:23:21 (7 лет назад)

var

  tmp, sum, i, n : integer;

 

function f (n : integer) : boolean;

begin

  f := false;

  while n > 0 do

    if (n mod 10) mod 2 = 1 then exit

    else n := n div 10;

  f := true;

end;

 

begin

  read (n);

  for i := 1 to n do

  begin

    read (tmp);

    if f (tmp) then sum := sum + tmp;

  end;

  writeln (sum);

end.

 

Ответить

Другие вопросы из категории

Автоматического устройство имеет два входа, можно подавать на них натуральный числа и наблюдать результат на выходе. По таблице наблюдений

определить правило, по которому автоматического устройство осуществляет преобразования информации.

составить программу нахождения S=1+2+3..+N

уровень 9 класса

что обозначает клавиша Page Up и Page Down????

ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!

Помогите решить , пожалуйста!

Даны целые положительные числа M и N. Сформировать целочисленную матрицу размера M х N, у которой все элементы J-го столбца имеют значение 5•J (J = 1, …, N). Вывести матрицу в общепринятом виде.

Читайте также

ПОМОГИТЕЕЕЕ!!!:С Введите с клавиатуры 5 положительных чисел.Вычислите сумму тех из них,которые делятся на 4 и при этом заканчиваются на

6.Программа должна вывести одно число:сумму чисел,введенных с клавиатуры, кратных 4 и оканчивающихся на 6.

С клавиатуры вводятся 100 чисел. Найти сумму тех из них, которые больше 10.

На языке Паскаль. Очень нужно!

Язык pascal ABC

Введите 5 положительных уныл чисел, вычислите сумму тех из них которые делятся на 4, и оканчиваются на 6. Если таких чисел нет, то вывести об этом сообщение.

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )



Вы находитесь на странице вопроса "с клавиатуры вводятся N произвольных натуральных чисел. найти сумму тех из них в составе которых отсутствуют нечетные цифры", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.