Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Для обеспечения высокой скорости обмена между двумя крупными городами страны, находящимися на одной параллели, с координатами (X1, Y) и (X2, Y), была

5-9 класс

проведена многожильная оптоволоконная связь. В дальнейшем решили подключить близлежащие посёлки к существующей линии. Все поселки должны быть напрямую подключены к основной линии без каких-либо разветвлений. Возникла задача – найти длину оптоволокна для интернетизации всех посёлков, если известны их координаты.

Входные данные

Marina190902 01 июля 2014 г., 12:58:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
34507аня
01 июля 2014 г., 14:07:51 (9 лет назад)

кто ж игрек ставит впереди икса?

 

var n,i:integer;
x1,x2,y,xn,yn,s:real;
BEGIN
  readln(у,x1,x2);
  readln(n);
  s:=0;
 
  for i:=1 to n do
  begin
    readln(xn,yn);
    s:=s+abs(yn-y);
  end;
 
  writeln(s:10:2);
END.

Ответить

Читайте также

1)Составить алгоритм для решения задачи: Вычислить угол между двумя векторами, если эти векторы заданы своими координатами.2)Составить

алгоритм для решения задачи: Найти действительные корни квадратного уравнения вида ax^2+bx+c=0.

Вычислите расстояние между двумя точками с данными координатами: (x1,y1) и (x2,y2)

Формула для нахождения расстояния: картинка снизу
И всё это в паскаль. Спасибо.

1. Компьютер это -

электронное вычислительное устройство для обработки чисел;
устройство для хранения информации любого вида;
многофункциональное электронное устройство для работы с информацией;
устройство для обработки аналоговых сигналов.
2. Производительность работы компьютера (быстрота выполнения операций) зависит от:
размера экрана монитора;
тактовый частоты процессора;
напряжения питания;
быстроты нажатия на клавиши;
объема обрабатываемой информации.
3. Тактовая частота процессора - это:
число двоичных операций, совершаемых процессором в единицу времени;
количество тактов, выполняемых процессором в единицу времени;
число возможных обращений процессора к оперативной памяти в единицу времени;
скорость обмена информацией между процессором и устройством ввода/вывода;
скорость обмена информацией между процессором и ПЗУ.
4. Манипулятор "мышь" - это устройство:
ввода информации;
модуляции и демодуляции;
считывание информации;
для подключения принтера к компьютеру.
5. Постоянное запоминающее устройство служит для:
хранения программы пользователя во время работы;
записи особо ценных прикладных программ;
хранения постоянно используемых программ;
хранение программ начальной загрузки компьютера и тестирование его узлов;
постоянно хранения особо ценных документов.
6. Для долговременного хранения информации служит:
оперативная память;
процессор;
магнитный диск;
дисковод.
7. Хранение информации на внешних носителях отличается от хранения информации в оперативной памяти:
тем, что на внешних носителях информация может хранится после отключения питания компьютера;
объемом хранения информации;
возможность защиты информации;
способами доступа к хранимой информации.
8. Во время исполнения прикладная программ хранится:
в видеопамяти;
в процессоре;
в оперативной памяти;
в ПЗУ.
9. При отключении компьютера информация стирается:
из оперативной памяти;
из ПЗУ;
на магнитном диске;
на компакт-диске.
10. Привод гибких дисков - это устройство для:
обработки команд исполняемой программы;
чтения/записи данных с внешнего носителя;
хранения команд исполняемой программы;
долговременного хранения информации.
11. Для подключения компьютера к телефонной сети используется:
модем;
плоттер;
сканер;
принтер;
монитор.
12. Программное управление работой компьютера предполагает:
необходимость использования операционной системы для синхронной работы аппаратных средств;
выполнение компьютером серии команд без участия пользователя;
двоичное кодирование данных в компьютере;
использование специальных формул для реализации команд в компьютере.
13. Файл - это:
элементарная информационная единица, содержащая последовательность байтов и имеющая уникальное имя;
объект, характеризующихся именем, значением и типом;
совокупность индексированных переменных;
совокупность фактов и правил.
14. Расширение файла, как правило, характеризует:
время создания файла;
объем файла;
место, занимаемое файлом на диске;
тип информации, содержащейся в файле;
место создания файла.
15. Полный путь файлу: c:\books\raskaz.txt. Каково имя файла?
books\raskaz;.
raskaz.txt;
books\raskaz.txt;
txt.
16. Операционная система это -
совокупность основных устройств компьютера;
система программирования на языке низкого уровня;
программная среда, определяющая интерфейс пользователя;
совокупность программ, используемых для операций с документами;
программ для уничтожения компьютерных вирусов.
17. Программы сопряжения устройств компьютера называются:
загрузчиками;
драйверами;
трансляторами;
интерпретаторами;
компиляторами.
18. Системная дискета необходима для:
для аварийной загрузки операционной системы;
систематизации файлов;
хранения важных файлов;
лечения компьютера от вирусов.
19. Какое устройство обладает наибольшей скоростью обмена информацией:
CD-ROM дисковод;
жесткий диск;
дисковод для гибких магнитных дисков;
оперативная память;
регистры процессора?

помогите пожайлуста))))))))))) Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из

моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

ввод:1, 1, 1, 2, 2, 2

вывод: 3661

ввод:1,2,30,1,3,20

вывод: 50

это задача на pascal ABC



Вы находитесь на странице вопроса "Для обеспечения высокой скорости обмена между двумя крупными городами страны, находящимися на одной параллели, с координатами (X1, Y) и (X2, Y), была", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.