Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

написать программу которая складывает числа до тех пор пока не получится число состоящее из одной цифры.

5-9 класс

пример:
5+5+5=15=1+5=6
он должен ответ складывать так как показано в примере как это сделать я не как не могу понять(

Canek528 03 нояб. 2014 г., 17:32:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olganeverova
03 нояб. 2014 г., 18:09:48 (9 лет назад)

var
  a, b: integer;

begin
  readln(a);
  while (inttostr(a).Length > 1) do
  begin
    b := 0;
    foreach c: char in inttostr(a) do
      b += strtoint(c);
    a := b;
  end;
  writeln(b);
end.
=======================
var
  a, b, e: integer;
  d: string;

begin
  readln(a);
  d := inttostr(a);
  while (length(d) > 1) do
  begin
    d := inttostr(a);
    b := 0;
    for e := 1 to length(d) do
      b += strtoint(d[e]);
    a := b;
  end;
  writeln(b);
end.

+ 0 -
Lukashintol
03 нояб. 2014 г., 20:25:18 (9 лет назад)

в паскале надо написать

Ответить

Другие вопросы из категории

Алёша, Боря и Гриша нашли в земле старинный сосуд. рассматривая удивительную находку, каждый высказал по два предположения:1)алёша:

это сосуд греческий и изготовлен в V веке
2)боря: это сосуд финский и изготовлен в 3 веке
3)гриша: это сосуд не греческий иизготовлен в 4 веке
учитель истории сказал ребятам, что каждый из них прав только в одном из двух предположений. где и в каком веке изготовлен сосуд?
решите,пожалуйста, через таблицу (0;1)

Читайте также

ПОМОГИТЕ НАПИСАТЬ ХОТЯ БЫ ОДНУ ЗАДАЧУ НА Pascal ОНИ НЕ СЛОЖНЫЕ , А Я ДАЮ МНОГО ПУНКТОВ!! За 2 лучший ответ! Без плагиата! 1.Написать

программу,используя оператор цикла While,которая будет вводить целые положительные числа не превышающие 100. Найти сумму квадратов чисел 2.Написать программу используя оператор цикла Repeat,которая будет вводить целые числа до тех пор пока не будет введён 0.Подсчитать среднее арифметическое введённых чисел.

Цикл с пост условием!! помогите

Написать программу которая будет вводить целые числа до тех пор пока не будетвведён 0. Подсчитать количество положительных и отрицательных чисел.

Написать программу

4. Компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит S. Чему равна сумма квадратов?
Подсказка:
Начальное значение переменной цикла – 2. Шаг изменения – 2 (перебираем четные числа).
Считаем сумму квадратов до тех пор пока она меньше или равна S.
Вывод на экран :
Результат:
s =
Тест 1:
Исходные данные:
s = 24
Результат:
s =56
Тест 2:
Исходные данные:
s = 85
Результат:
s =120

Помогите с задачей.

Вводится последовательность целых чисел, до тех пор пока не введено число n
Найти сумму положительных среди них?



Вы находитесь на странице вопроса "написать программу которая складывает числа до тех пор пока не получится число состоящее из одной цифры.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.