Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

вводится 6 чисел выводится сумма всех отрицательных если их нет так и должно писаться нет значений. необходимо написать программу в форме диалога на

5-9 класс

паскале

Moon76 24 июня 2013 г., 8:00:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Azamat01
24 июня 2013 г., 10:10:03 (10 лет назад)

var b,c:real;
a:integer;
begin
c:=0;
writeln('Введите числа');
for a:=1 to 6 do
begin
readln(b);
if b<0 then c:=c+b;
end;
if c=0 then writeln('Нет отрицательных чисел')
else writeln(c);
end.

Ответить

Другие вопросы из категории

Паскаль:

Составить функцию нахождения объема цилиндра по его радиусу основания r и высоте.
С помощью данной функции вычислить объемы для N цилиндров.

я не могу быстро печатать

помогите

Читайте также

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на

вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4. Пояснение: цикл while x<>0 do с условием if (x mod 6=0) and (x mod 10=4)

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

1)среди 15 чисел найдите сумму всех положительных чисел

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными



Вы находитесь на странице вопроса "вводится 6 чисел выводится сумма всех отрицательных если их нет так и должно писаться нет значений. необходимо написать программу в форме диалога на", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.