Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан одномерный массив из 10 следующих элементов:

10-11 класс

3,0,1,7,4,5,6,2,9,0.

Как изменится порядок элементов после выполнения фрагмента Паскаль-программы описанного ниже?

...
for i:=1 to 5 do
begin
t:=a[i];
a[i]:=a[11-i];
a[11-i]:=t;
end;
...

DeVohKaa 04 дек. 2016 г., 22:13:01 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
егор7770
05 дек. 2016 г., 0:21:44 (7 лет назад)

3)0,9,2,6,5,4,7,1,0,3 Инверсия массива...

Ответить

Другие вопросы из категории

Современные видеокарты могут поддерживать разрешение 2560*1600 пикселей при глубине цвета 32 бит

Размер буфера кадра при этом равен 16 Mb
Вопрос : Какая пропускная способность шины потребуется, чтобы вывести такой буфер кадра на монитор с частотой 75 Hz?

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Дан одномерный массив из 10 элементов. Элементы массива лежат в диапазоне от -20 до 20 и обозначают температуру первой декады (10 дней) марта. Определите

номера дней, когда температура опускалась ниже -10. Напишите программу, которая позволяет найти и вывести номера дней, когда температура опускалась ниже -10.



Вы находитесь на странице вопроса "Дан одномерный массив из 10 следующих элементов:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.